VIM3L HTPC | AAC surround broken when playing movies on the latest CoreElec update

Folks, my VIM3L HTPC upgraded CoreElec 4-5 days back automatically, and since then any movie with AAC audio is broken with distorted audio. Movies with DTS, Dolby Digital etc. have no problems with playback. The same movies sounded perfectly fine before the upgrade.

I have a Sony STR DN1080 receiver configured in a 5.1.2 setup.

Can others having the issue chime in?

Hello! look in the settings for coreelec / sound settings, the main audio output and transcoding.Set everything according to your scheme!

Hi Vladimir, thanks for responding. I already checked all audio related settings. Have done my homework and then posted this message.

@Gouwa, @tsangyoujun, how can I downgrade to the previous version of CoreElec? I’d like to revert to the previous version until you guys fix the issue.

Two-channel and multi-channel AAC are fine.
on vim3L there should be no problems with decoding, CoreElec 9.2.2 also works stably, try resetting to factory settings.

1 Like

Thanks for the confirmation Vladimir. I don’t have any issues with AAC stereo; it’s only the surround format getting distorted.

Also, I did some troubleshooting and found that the decoding gets distorted when Kodi Settings -> Audio -> Audio Output Device is set to ‘ALSA AML-AUGESOUND, HDMI’. I have tried remapping the format to all possible formats supported by the receiver (Neural X, Dolby Surround, Multi-Channel Surround etc.), but to no avail.

While setting this to ‘ALSA AML-AUGESOUND, HDMI Multi Ch PCM’ mitigates the issue, my receiver is unable to display the type of decoded audio. I have been using the VIM3L with the parameter set to ‘ALSA AML-AUGESOUND, HDMI’, with which things were working fine, until the recent automatic (my update method is set so) CoreELEC upgrade to the VIM3L.

What’s your receiver, btw?

I have vim3 pro / HDMI / TV / optics/speakers, but I want to note that vim3 L supports ARC. Have you tried resetting to factory settings? this is sometimes recommended. As for my observations, I like 9.2.2 more, since 9.2.1 had problems with IPTV, for example. By the way, I tried to find films with multi-channel AAC, it is such a rarity, but I found it, and it also works well! :slight_smile:
But if you still decide to go back to 9.2.1, then Krescue will help you , the only thing there with the Internet enabled can start updating, you will be ready!

Yes, I had tried the reset to factory settings as well. Not sure if the CoreElec builds are the same for VIM3L and VIM3 Pro, and act differently with differences in the boards.

Anyway, thanks for chiming in. For now, I’m using the ALSA AML-AUGESOUND, HDMI Multi Ch PCM setting as described earlier.

I will post the solution, if I find one through my troubleshooting process.

this question can be asked in the CoreElec community https://discourse.coreelec.org
especially since Khadas is officially supported by CoreElec! :slight_smile::+1:

Yes, will post a question there.

Благодарю вас :slightly_smiling_face:

1 Like

I have the exact same issue and solved it using this method.

Can anyone acknowledge that this is on the known bug list?

P. S. I’m on 9.2.3 but can confirm the bug existed on 9.2.2 also.

So I was not the lone victim of this issue; whew! Could you let me know what method you used to solve?

Thanks and Regards.

1 Like

hoodafukisalice,
Hi,
By the way, you did not ask a question on the coreelec forum?

Nope, I forgot. Thanks for prodding; will post there.

Will see what @Jimibob has to say as well about the solution.

1 Like