VIM3L HDMI not workig


I have been working on VIM3L, Ubuntu genome 4.9 image.
HDMI was working fine initially, it stopped working suddenly.

I have tried Pie-v201113 , couldn’t see anything on screen (display connected through HDMI to TV)
Tried krescue image as well, couldn’t see anything on screen.

HDMI port works fine, tested it with Laptop.

Kindly suggest some solution to this.

@ydwkhadas @jasonl and @Terry will help you


Please suggest a solution

did u try any boot other OS ? its can help clarify your real problem ! just try start krescue from sd if display same didnt works - inform us! and we can help u

If you don’t use krescue and only burn the latest firmware, will the display be normal?
Can you provide the boot printing log for me? Thanks!

Yes, tried Andriod Pie , couldn’t see anything on display either.
Tried Krescue as well , got the image on SD card , but cant see anything on TV screen.

I was working on Ubuntu- gnome- focal-linux-4.9 image.

Still cant see anything on dispaly.

looks like mechanical or hardware problem with your board

Can you take a picture for your VIM3L board? We want to check it.

@ydwkhadas the contacts and the soldered connections are the critical points you should be photographing :slightly_smiling_face:

p.s that means you would need to remove the heatsink.

@ydwkhadas that is the bottom side, HDMI connections are on the other side, try removing your heatsink and take the photos.