VIM3L EMMC Missing

I am new to VIM3L and I just bought one unit to try out. Not sure what went wrong, but I find all my emmcblk missing. I did see a few before, like emmcblk0, emmcblk1p1, emmcblk1p2, etc. Can anyone advice how I can get back all these emmc contents? Or best is how can I restore back to unbox condition? I did not do any backup though I found out I could have dump an image to an SD card first before doing anything, but now it’s too late.

try Krescue dl.khadas.com - Index of /Firmware/Krescue/

  1. boot Krescue from sd
  2. make full emmc dump for next restore
  3. check emmc
  4. install any system if cant restore prev system

Good-luck

I am able to go into Krescue from SD, but the condition of the emmc now is not what I want, so what you mean “make full emmc dump for next restore”? I don’t have image of the unbox VIM3L.

  1. if u have some data which need to restore why not try
  2. if u need just start android or other os is very easy just install it via Krescue wizard

But your point 2 (make full emmc dump for next restore) means I actually make a copy of the current emmc right? But that is not what I want.

I want to put into the VIM3L a factory default with the right emmc original partitioning. Is that possible? Like a factory reset.

  • if u need just start android or other os is very easy just install it via Krescue wizard

Then how about the partitioning of the emmc? Is it important? I did try to write into the emmc an image but after the OS run, I check the dev folder but do not see the usually mmcblk files. Is it normal?

I am not working with Android; I need to prepare the board for Ubuntu 18.04 LTS.

if u need any OS is very easy just install it via Krescue wizard