VIM3L: Can't boot into USB upgrade mode

I have the VIM3L HTPC Kit (SKU: KVIM3-L-005) and I’m not able to have it boot into USB upgrade mode.

I’ve tried the steps from:

Power-on VIM3.
Quickly press the F button 3 times in 2 seconds, then release the button.

You will see the Power-LED (Blue) blink for about 3 seconds. After the Power-LED (Blue) turns OFF, this indicates that the board is in Upgrade Mode

But it doesn’t work; it always boots into “CoreELEC” software.

Pressing the reset button causes the device to go system LED to boot straight into “White LED / CoreELEC”.

Pressing the function button (3 times) during power on causes the blue LED to flash for a short time (1-2 seconds), but CoreELEC still boots (there’s no boot menu).

Hello, the first boot will always be from sd / usb, if you have already booted there once, select “power settings” in coreelec and “Reboot from eMMC / NAND”.

This is not provided in vim3 / L

Hi, thanks for your suggestion. In the CoreELEC there is “Power Options” with 5 options:

  1. Power off system
  2. Custom shutdown timer
  3. Suspend
  4. Reboot
  5. Restart Kodi

I don’t see “Reboot from eMMC / NAND”.

I tried “Reboot” with/without pressing function key 3 times with no success. Also rebooting into CoreELEC.

Okay, where do you have your Coreelec system, internal (eMMC) or external (sd / usb) storage?

CoreELEC system is on the internal eMMC as shipped by Khadas.

Then everything is clear, only one OS can be installed on the internal eMMC! that’s why you don’t have an eMMC / NAND item.

I understand you want Android / coreelec?

Here’s the latest official release, it’s better to flash through UBT.

https://dl.khadas.com/Firmware/VIM3L/Android/VIM3L_Pie_V201113.7z

I also give you a link to the instructions for the firmware.

The Amlogic USB Burn Tool steps https://docs.khadas.com/vim3/UpgradeViaUSBCable.html#Upgrade-steps say:

Connect your VIMs to your PC with a USB-C data cable (VIMs will power on automatically).

Place your VIMs into “Upgrade Mode”:

Long press the Power key without releasing it.
Short press the Reset key and release it.
Count to 10 seconds and then release the Power key.

And these steps fail on my VIM3. It always boots into CoreELEC.

SOLUTION: DO NOT connect HDMI output to a receiver/TV when attempting to enter USB upgrade mode. USB upgrade mode will NOT work when HDMI output is connected to receiver/TV. It will always boot into CoreELEC. Only connect Power/USB to VIM3L when attempting to enter USB upgrade mode. With only Power/USB connected, press Function key 3 times and it should enter the USB upgrade mode (verified using the Windows Amlogic USB Burn Tool v2.2.0 detect the connected device as “HUB1-2” Status “Connect success”).

@dwhea you can always use maskrom mode,
3 clicks of the function (middle button) within 2 seconds of startup.