VIM3L Boot Logo on Android OS Problem

Im running a VIM3L with Android OS (VIM3L_Pie_V210527) and have been struggling with boot logo customization for couple of days so here i am asking for expert’s advice.

My aim is to change Khadas’s boot logo as well as Android boot logo and so far i tried everything that was mentioned in other forum threads but none seemed to work in my case.

I have two issues:

Issue number1:
I used "Amlogic Customization Tool v2.0.10, loaded the image.img (VIM3L_Pie_V210527) and selected Set logo and unpacked, changed Poweron Logo and Bootup logo in many different versions (BMP formats, png, jpg) but none seem to do any good. If i put png or small BMP then instead of my added logo or khada’s logo i just get Black/Blank screen and then move over to Android logo and bootup, if i use big BMP as with full screen 1920xXXX then USB_Burning_tool just throws an error at 11% and wont write the .img file. so is there a better .img extractor which is compatible with android 9 on khadas ?
Almost forgot, i am using a Windows 10 and uploaded the firmware using USB_Burning_Tool, i even tried using adb commands and uploaded the .img file into khadas and from there with the commands provided in another khadas thread i installed the .img but still samething… no khadas or custom logo, it just becomes black/blank.

Second issue:
for android boot logo also i tried many different scenarios that were mentioned online but with that also i hit the wall.
So first i started by modifying but no matter the format and images i put (even i tried to add simple lines onto the original android logo) i get blank screen (colorful android is gone) and then comes the White/gray android logo and once any change is made to in the booted up android’s main screen i get issues like background screen becomes black and an error keeps showing up saying “Process system isn’t responding” xClose app, or xWait.
(and to answer your qustions about zip file, it was compressed as Store and i followed all the instructions carefully, even as i mentioned before i only adjusted some stock png files and added simple lines over them and still had this issue)

so any help will be greatly appreciated regarding both issues, having blank khadas logo is not an issue since its not showing anything and i just get a blank 3-4 sec screen but android logo is far more important for me (both colorful logo and white/gray android text) as i want them gone or exchanged with another logo.

Thank you guys and sorry for the long read.

@AcidA you can refer How To Change Boot Animation | Khadas Documentation


You can upload the file you made to the cloud disk. I can help you see why.

Would you mind explaining how i can access the folder device/khadas ? I am a novice user.
I am also using windows, should it be accessed via windows and adb commands or android root ?
Also is amlogic customization tool working for android 9 img ? Shall i do both amlogic img and also modify device/khadas folder image replacement ? Or just the folder would do the job ?

This is the source code directory. So you need to download the source code, replace the corresponding files, compile and upgrade the firmware.

Can i do this on windows 10 ?
I searched in the forum but the links goto a 404 page and cannot find any info about it.

If linux is required im stuck but if it can be done via windows 10 it would be perfect if you could guide me toward the right direction…
Like what softwares are required to get this done, adjusting images is easy but how to recompile it back and load it to device ?


Ok, finally i managed to change the file a way that it shows up once device is booting up into android but the issue is that once its booted in android i keep getting this error and apps keep on closing:

“Process system isn’t responding” Close app or Wait

Do i need to adjust or modify any other file in android after making changes to ? My animation is showing up the only issue is the error that keeps showing up after android has run for 1-2minutes.


You can see if this bug will come out without any modification? First judge what caused it.

I have the same error, it is enough to make the “systems / media” folder writable and then return it to read-only again.

I tried it on firmware VIM3_Pie_V210908 and VIM3_Pie_V210527. It appears in the same way.

@antigua i will fix the problem

Please post how you solved this problem.

device/khadas directory ,revert 31a9909506573200159b6db9e178e07bb481f123 commit

the commit date is April 1st, but I downloaded the firmware 2 days ago and the problem exists. With the help of the root explorer , I try to replace the bootanimation, and as soon as the system / media folder receives the write status and after I return the read, this error appears.

maybe solved this problem only for VIM3 L

I will compile this change to the next firmware

I somehow fixed the issue but not in a logical way… you have to stick with same image size (resolution) and even the number of png files in each folder and it should work (atleast thats how it worked for me)

What is your board? after a lot of attempts to replace bootanimation, I got to the point that it is enough to remove the read-only mode and return it back using the root explorer. and the error manifests itself. in doing so, I keep the original file.