VIM3L boot animation


I am trying to update the boot animation in the VIM3L.

I am following this post.

I fetched the current animation from the VIM3L:

adb pull /system/media/

This fetched the zip file to the current diectory.
As a first step / experiment, I tried to push this same zip file back to the VIM3L:

adb push /system/media/

The error that came back is:

C:\dev\android adb\platform-tools>adb push /system/media/
adb: error: failed to copy ‘’ to ‘/system/media/’: remote couldn’t create file: Read-only file system 1 file pushed, 0 skipped. 23.8 MB/s (5843557 bytes in 0.235s)

When I right-click on the file, in Windows Explorer, it doe s NOT have th erwead-only attribute.
Am I missing a step? DO I have to put the VIM3L into a certain mode, before pushing a new boot animation to it?

After reading some posts, I did the following:

adb reboot
adb root
adb remount
adb push /system/media/

The push seemed to be accepted, but now when I boot the device, after the boot logo, I see the following:

  • The animation is NOT displayed
  • Instead, the app icons are displayed, and the screen background is black
  • After approximately 30 seconds, a prompt is displayed, with two options:

Process system isn’t responding
With options:

Close app



@gar1234 Please ensure that your file is of the right format, with all the right files in their respective directories. and you have a return/next line on the desc.txt of the bootanimation.

Also make sure that the file is packed with compression as 0 (not compressed).

If you read my post again, you will see that I did NOT generate a new zip file - I just went to push the exact same file that I fetched.
And it wasn’t accepted.
And now because of the reboot, root, remount commands I have used I think I have totally messed up my device

What can you suggest please

Okay I will try from my side and let you know.

By the way, I re-installed the Android image, using the OOWOW tool, in case I had messed up anything with Android when I used the reboot, root, remount commands.

I ran these commands, to fetch the boot animation, and to push it back:

adb devices
adb pull /system/media/
adb push /system/media/

But I still get the same “read only” error

I used those commands to verify it on my local machine, and it was no problem. Let’s see which step was missed.

C:\Users\Xiong>adb pull /system/media/
/system/media/ 1 file pulled, 0 skipped. 8.9 MB/s (5843557 bytes in 0.629s)

C:\Users\Xiong>adb root
restarting adbd as root

C:\Users\Xiong>adb remount
remount succeeded

C:\Users\Xiong>adb push /system/media/ 1 file pushed, 0 skipped. 35.1 MB/s (5843557 bytes in 0.159s)

C:\Users\Xiong>adb reboot

1 Like

Okay, that worked - I copied what you did.
For zipping up an animation, I don’t think it is sufficient to use the Windows Explorer utility: “Send to - compressed (zip) folder”.
The reason I say this:

Step 1: I fetched the existing file
Step 2: I unzipped it.
Step 3: I re-zipped it (using the “Send to - compressed (zip) folder” option in Windows Explorer). THe zipped file name is:
Step 4: I pushed the zip file to the VIM3L:

adb root
adb remount
adb push /system/media/
adb reboot

As before, I did not get the animation to display - just a blank screen.
Q1: Is there a different way that I should be creating the zip file?
Q2: And/or do I need to modify the attributes of the file, after pushing it to the VIM3L (and if so, how do I do this)?

Here’s how to make it

I understand hat, thank you, but you have not addressed my questions.
I am using a Windows PC, not a Linux PC.
I asked you was it sufficient or not to use the Windows Explorer utility: “Send to - compressed (zip) folder”.

You can use compression software on Windows to compress. The compression format is ZIP and the compression method is storage. This is the key point.

Are you saying I need 3rd party compression software to run on my Windows PC?
Your answers really are not very clear or specific.
This post started THREE WEEKS ago, and I am still trying, so I would really appreciate if you make the effort to be more clear and precise

@gar1234 you can use 7zip and in the zip compression settings you can disable compression, by setting compression level to store.

Success thanks, I will close this ticket

@xiong.zhang please check Android VIM3/3L crashes system.ui when modify file.

I don’t understand what you are saying - can you explain a bit more please