VIM3 Upgrade mode

Is there any other way to put VIM3 into the upgrade mode?
My power + Reset is not working.
Can I use adb shell to put my VIM3 into upgrade mode?
I have tried ‘reboot bootloader’ but it is not working.

hi ,
yes, do a triple quick press of the middle button, preferably in the USBBurningTool to monitor this action.

nothing is said about it


Okay. Let me check.
I Will let you know.

1 Like

I got it working.
One more thing. Which tool should I use to upgrade VIM3?
burn-tool or aml-burn-tool ?
I am working on ubuntu 16.04.

AmlogicBurningTool will do

I tried burn-tool and I was able to flash my image but it did not do the reset after successfully burning. I had to do the reset manually.

Burn Logs:

Unpacking image [OK]
Initializing ddr …[OK]
Running u-boot …[OK]
Create partitions [OK]
Writing device tree [OK]
Writing bootloader [OK]
Wiping data partition [OK]
Wiping cache partition [OK]
Writing boot partition [OK]
Writing dtbo partition [OK]
Writing logo partition [OK]
Writing odm partition [OK]
Writing product partition [OK]
Writing recovery partition [OK]
Writing system partition [OK]
Writing vbmeta partition [OK]
Writing vendor partition [OK]
Resetting board [OK]
Time elapsed: 2 minute(s).

Yes, it is a bug about G12 chips. But it doesn’t matter.

I can do a manual reset though.