VIM3 sound to quiet with toneboard


I have a VIM3 with the most current android version and a tone board.
Until today it worked flawlessly until it suddenly turned the volume down.
Making it louder in the settings wouldn’t work.

If I plug the toneboard in my pc, everything works fine again.

How can I resolve that?

I noticed when only the first 3 steps seem to work with the volume.
Over 3 steps the sound does not get louder or softer when changing it.

Reboot and reconnecting tone board changes nothing.

Hey. Hard reset Android to factory settings and check again


I have done this, but the issue is still there…

Edit: I reseted a second time, then it was working.
Tried three reboots and suddenly it is quieter again…

For our application we have some nodes and can’t reset android all the time…
Is there something I can do from the terminal / adb?

Do the gpio pins fit well with the vim board?


the board is connected via pins (soldered directly).

Yes, check how tight the pins are in contacts.

Hello, I have soldered the pins directly from the vim to the tone board. It cannot be removed. It is in good contact.

You said that everything works well with the PC, while there is a problem with the vim board, so I think that somewhere there is a bad contact in the TB + vim bundle


I have checked for that first.
Even if there was a weak contact I cant understand why that would make the volume lower and not just output nothing at all.

Please note also, that moving the volume bar in android over step three does not change the volume, only changing it under Step 3 changes the volume.

in vain you think so, just the board can behave differently, it is not necessary that it will not work for you at all, the very concept of “bad contact” or “no contact at all”, these are different things.

Try turning on the sound and shaking the board a little (not much).

as @Vladimir.v.v recommended, did you try backing up and reflashing Android to see if that works ? because it could also be some stubborn byte that is refusing to change the volume…

1 Like

Yes and it worked shortly but then went nuts again.

It was better with the March Android release, I think.

Do you update Android via UBT?

Updated Via USB-C-Cable

UBT (usb burning tools), I call the flashing tool

Yes I used that tool on Windows.

Well, if you have no problems with a different version, then there is probably a problem with the firmware

How could I debug the volume issue?

ugh, you still have a problem? :slightly_smiling_face: