VIM3 Pro won't stay powered on

Ever since I downloaded the latest Android Pie version for VIM3 I haven’t been able to boot into my VIM for more than a handful of seconds. I assumed that it must have burned incorrectly or maybe there’s an issue with the new release.

I thought it wasn’t an issue and I’d go back a version, but no, this is constant now. Despite the fact that it will happily stay on to burn a new image, it will not stay active for more than a handful of seconds (even if only the sub-c power is connected)

Hello, What are you using to power the VIM3? If possible, try a suitable substitute power supply.

@Fuiphler Which one firmware you burn into ? Do you use external power supply ?

USB-C connector. Normally it is fine even just plugged into my computer, but I usually use it attached to a wall socket. I’ve tried three different usb-c connectors and two different sockets, as well as powered through the computer.

VIM3_Pie_V200319.7z, but I tried to revert back to V200103 to see if this would fix the issue. I normally use an external power source, no issues in the past.

did your firmware go 100% correct? which LED is on? Have you checked the HDMI cable?
usually the cable from the power supply gets worse over time, the contacts go away.
if everything is ok try logging in to Krescue

Latest burn-in .exe and it went 100% fine, several times as far as it looked and reported. It’ll boot with solid white LED, flash red led once during boot, then usually turn off as, before or a little while after making it to android home. Used two different hdmi cables, but quickly found that it will make this behaviour without any hdmi attached. I will try working with Krescue in a bit now I’m back from work

yes, it will be good, now it’s important to understand that this is the software part, not the hardware

With that in mind I first tested the lastest eMMC linux build as well as krescue for eMMC and both showed similar behaviour, although, when linux was burned in it did sometimes manage to stay on for almost a minute occasionally.

I did make an SD card with krescue however and that had no issues booting in and even displaying an image using my normal setup. No shutdowns! So I’ll try to gather infomation that way tonight

good news ! let me know the final result🙂

In conclusion, and after waiting weeks to receive all new wall chargers, USB-C cables, HDMI cables. Is that, for whatever reason, the VIM 3 will not display an image onscreen without power supplied from the computer. Keeping cables unchanged but from 4 different wall chargers. Then rotating through cables to test the cables. Then rotating HDMI cables… showed only a black screen.

Then, when it is powered by a computer it will only display, as before, until it has reached or just finished the boot screen in android and krescue, or at a specific point at around 6 secs into ubuntu… then it will turn off; however now, in android, it will try rebooting, and make it to the logo screen and stop there indefinitely.

Only twice have I managed to get it to boot into krescue long enough to use the OS, and nothing I’ve found (though I’m admittedly an amateur at all this) seems to indicate the root cause of these issues; so I think I’m just going to have to send it in under warranty, as these issues are beyond me and have gotten in the way of enjoying trying to use the device :frowning:

A power supply of 5v at 2 amps or better is recommended. I missed what type of USB port you are using on your laptop.
If your chargers are smart chargers, depending on type, they may not allow sufficient current or volts.

I know. But as the VIM works now, I either have to choose between not getting video output, or not getting power. That’s my point, and it just suddenly started doing it (several weeks ago now). Because I can’t find a fix and it’s behaviour is independent of a single accessory, or OS, I’m going to send it back because I can’t use it as I did before

@Fuiphler Do you know how to use serial tools ? Can you give us a full info bia serial tools. It can use for Analyze problems .

I don’t really, I could try buying a debugger and learning, but I wasn’t looking to try learning to debug a broken piece of hardware. It was more of a hobby project making a stylish jukebox

I went through 2 edges and a captain. Both systems displayed that exact behavior. I’ve been without a project for weeks because i got fed up and sent them back. Looking around for a replacement i came back to check out the VIM3 Pro but after seeing this post No Way am i going to spend more time and money for another headache. Both of mine gave a screeching sound when the usb C power was plugged in while either the hdmi or other usb c was also plugged in. Did yours make any sounds? I had 1 device booted into OS 1 time and the other 2 times and then kapoot. Sorry to hear about your issues but I think you saved me from repeating a mistake the for the third time.

Have you tried to send the device for diagnosis, and confirm the problem of the device itself?

To be honest, I really doubt that two or three devices in a row will not work

And the first question arises, do you have an original power supply and cables from Khadas, including HDMI?

Sorry to here this :frowning: I’ve actually had this for a fair few months, and managed to power it with display maybe 50+ times using the equipment I had already, though admittedly not for huge amounts of time (as might be the case for the completed project). So not a one-and-done, but not too reassuring either I guess. There isn’t any sound when plugged in. This is really just a sudden shift in behaviour, just wish I was able to reverse it :confused: