VIM3 Pro - no HDMI?


I purchased a VIM3 Pro back in August 2019 - and I never opened the box!
Anyway, I had a use for it today, so I opened it up and tried to use it - no HDMI output.

It responds to ethernet pings, but I never get anything out of the HDMI, no SSH - so I’m basically blind - I have no idea what to do.

I’ve copied images to the SD, and done the triple-function-click… dont think it made any difference.

Where do I go from here?


More info… I’m ssh’d into Ubuntu (emmc), and this is output when I plug in HDMI

[ 454.936175] hdmitx: system: irq 80000002 0
[ 455.447795] hdmitx: system: plugin
[ 455.580091] hdmitx: edid: EDID Parser:
[ 455.580098] hdmitx: hdmitx: reach vesa idx MAX
[ 455.580102] hdmitx: hdmitx: reach vesa idx MAX
[ 455.580105] hdmitx: hdmitx: reach vesa idx MAX
[ 455.580130] hdmitx: edid: get dtd0 vic: 0
[ 455.580136] hdmitx: edid: find IEEEOUT
[ 455.580158] hdmitx: edid: check sum valid
[ 455.580161] hdmitx: edid: check sum valid
[ 455.580167] hdmitx: edid: update rx hdr info 0 at edid parsing
[ 455.580172] hdmitx: edid: check sum valid
[ 455.580175] hdmitx: edid: check sum valid
[ 455.580180] hdmitx: edid: blk0 raw data
[ 455.580205] hdmitx: edid:

[ 455.580209] hdmitx: edid: blk1 raw data
[ 455.580234] hdmitx: edid:

[ 455.580238] hdmitx: system: update physcial size: 190 330
[ 455.580247] hdmitx: system: get current mode: 1080p60hz
[ 455.580251] hdmitx: system: update rx hdr info 0
[ 455.580254] hdmitx: system: update physcial size: 190 330
[ 455.580285] hdmitx: video: already init VIC = 0 Now VIC = 16
[ 455.580290] hdmitx: hw: div40: 0
[ 455.609815] hdmitx: frac_rate = 1
[ 455.609823] hdmitx: config HPLL = 5940000 frac_rate = 1
[ 455.609881] hdmitx: HPLLv1: 0xdb3a04f7
[ 455.609884] hdmitx: config HPLL done
[ 455.609892] hdmitx: set_hpll_od3_clk_div[610] div = 6
[ 455.609899] hdmitx: j = 4 vid_clk_div = 1
[ 455.609906] hdmitx: set enc for VIC: 16
[ 455.731797] hdmitx: hw: config hdmitx IP vic = 16 cd:4 cs: 2
[ 455.741897] hdmitx: video: Sink is HDMI device
[ 455.741932] hdmitx: hw: set audio
[ 455.741939] hdmitx: hw: hdmitx tx_aud_src = 0
[ 455.741952] hdmitx: fs = 2, cd = 4, tmds_clk = 148352
[ 455.741956] hdmitx: hw: aud_n_para = 8918
[ 455.741966] hdmitx: hw: set channel status
[ 455.741997] hdmitx: audio: Audio Type: PCM
[ 455.742001] hdmitx: hw: set audio
[ 455.742005] hdmitx: hw: hdmitx tx_aud_src = 0
[ 455.742017] hdmitx: fs = 2, cd = 4, tmds_clk = 148352
[ 455.742020] hdmitx: hw: aud_n_para = 8918
[ 455.742030] hdmitx: hw: set channel status
[ 455.742061] hdmitx: audio: Audio Type: PCM

With the monitor on and connected to the board try to boot oowow from SD card. That should give you a blue screen with a menu box. If that does not work you have a hardware problem.

Thanks @foxsquirrel

Yep oowow, krecovery, and all the images are the same story.
I suspected as much when I got no video output right out of the box - but I could see ADB ports 4000 and 5555 - meaning Android had booted.
Then I tried the Khadas EMMC Ubuntu, which flashed fine - and I was able to shell in and dump dmesg, but still no video.

Gosh bad luck, the one time I decided not to test a purchase. My VIM2 was perfect, still runs great. I only bought the VIM3 because there was a $20 discount at launch, so it sat in my “stock” until I decided to use it this week to see if it ran HAOS/Scrypted better than my overclocked Pi4.

Stumped how something as obvious as nonfunctional HDMI managed to make it through QC…

Darn. Guess it’s destined to eternally be a headless unit.

Here is what happened to me, bought some evm boards directly from TI. The first one would not boot, they would not take it back and told me to use the TI forum. Well I did, two of the actual TI employees told me how to go about burning an SD card and that I was not doing it correctly. Then they said the SD cards were bad… Then another one realized I know what I am doing and sent a replacement board. That board is dead too, I got tired of going back and forth with a bunch of fools. Dumped TI and decided on NXP stuff, TI is a huge company…

Might try to PM @rubywen about the board having dead HDMI.

You can try to erase the images in eMMC and then boot up the systems on SD cards.

1 Like

Hi Ruby,

I am already booting from SD card. It doesn’t matter if I boot from SD, or from eMMC, HDMI does not produce any output.

What are you suggesting?


You can check if there are any images in eMMC memory first and then erase them from eMMC.
Secondly, you try to boot from SD.

Hi Ruby,

I have done this. eMMC is erased. I boot from the SD. It does not fix the issue. No output signal on HDMI.
Where can we go from here?

Hello @nimble99

Waht’s the resolution of you screen? Have you also checed other screen or images?

Hi @numbqq
I’ve tried a variety of monitors, DELL 1080p, LG 4k, Samsung 1080TV, etc.
My VIM2 works on all of them. VIM3 works on none of them.

I have tried a range of your O/S images, for both SD and eMMC. They boot fine - never get any HDMI output however. See my logs above showing dmesg output from your eMMC Ubuntu image. Operating system is clearly working fine - and yet, no HDMI signal. Monitors just go to into powersave mode like nothing is plugged in.

Oh, and yes, my cables are fine. Tried 3. They work with VIM2.

Hi @nimble99
Do you have the order records? Which platform did you order the VIM3 from about 3 years ago?

Hi @rubywen

Yes I ordered it from - Mr Kingsley helped me with the order as I had trouble getting the discount code for the $20 discount to work.
I can DM you the order number

Mostly like you had dead hdmi.

I had one like that. Khadas was kind to replace it.