VIM3 pro no HDMI output

my vim3 that was working fine, mainly used via SSH.
lately I noticed that the HDMI no longer shows anything.
I didn’t change any settings, running on Ubuntu server - latest.
I did try to load Krescue but still no HDMI output

Hello, Am I right to assume you have tried different cable and/or display?

@rider Could you have used it? Still can’t use it all the time . I suggest you make an SD boot card from
SD starts an unmodified firmware to see if HDMI has an output

1 Like

Most of the time it is the cable or the resolution. Please try a different cable and different screen to cross verify. AFAIK the Khadas logo so appear when you power on the device and if that’s not coming then either its the TV Screen, cable or lastly the HDMI Port.

Also make sure that you have connected the cable when the device it off and power on the device so uboot detects the HDMI connection to output the Khadas Logo.

If you can see the Khadas logo but no output on ubuntu Kernel load then its something in the kernel.

If you need more help then you can share more information on what all you have tested.

1 Like

@Frank @Spikerguy
We have 5 vim 3 pro in office.
Tested with 3 screens and 3 cables, all PC screens, other vim3 units work fine with all screens and cables.
No logo is shown in eMMC boot nor uSD boot, beside the screen issue the device is working via ssh.

Then is must be the hdmi port.

The port on the vim3?

@rider Can you tell me what resolution is your monitor .Some resolutions are not supported.

3 screens i have tested - all FHD (1920x1080) :
Lenovo, Samsung and Dell.

@rider When you boot , did you see the uboot log ?

No output to HDMI at all.
please read my other comments

u can provide some useful information
if u have UART of SSH access to system
plz show => boot log from serial console (UART) + dmesg - from linux console <=

@rider Check if there is any problem with your power supply. If there is no problem, the HDMI port may be broken .

@Frank power supply is OK as my other boards work fine.

log files are located here:

tnx for logs

Manufacturer: DEL Model a0dc Serial Number 876041538

i can see your board can detect monitor! (in UBOOT stage and linux kernel same detect your monitor)

if display didn’t works maybe partial broken onboard hdmi connector or some pins or something around this


u can check hdmi connection by command line

grep "" /sys/class/switch/hdmi/state
grep "" /sys/devices/virtual/amhdmitx/amhdmitx0/disp_cap
grep "" /sys/devices/virtual/amhdmitx/amhdmitx0/edid

for example my output

root@Khadas:~# grep "" /sys/class/switch/hdmi/state
root@Khadas:~# grep "" /sys/devices/virtual/amhdmitx/amhdmitx0/disp_cap
root@Khadas:~# grep "" /sys/devices/virtual/amhdmitx/amhdmitx0/edid
Rx Manufacturer Name: PHL
Rx Product Code: c0de
Rx Serial Number: 0000179e
Rx Product Name: PHL
Manufacture Week: 15
Manufacture Year: 2014
Physcial size(cm): 62 x 34
EDID Version: 1.3
EDID block number: 0x1
blk0 chksum: 0x93

PS: if other board works fine in same situations ! this board is defective!

will have to act through a type display TS050?