VIM3 Pro , doesn't boot anymore from emmc and sd , if any os else OpenWrt installed

Hello all,

at the begin, I could install and test each os over krescue. Booting from emmc was OK.

But there were always some config problems , so i wanted to try other OS’s. Then i installed OpenWrt over Krescue. OpenWrt was’nt OK for me ,( issues with a second wifi card etc.). I saw armbian and installed it on sd, It hasn’t booted and i burn it to emmc with dd, but it didn’t work too. After this I have been getting problems. Now it can boot from SD only, if Krescue is installed on SD. It doesnt boot from emmc anymore (install all OS’s with Krescue )

I tried to full and fast format emmc. I didn’t help too.
I tried with USB Burning Tool and installed Android, I didn’t boot , It shows only the boot image of khadas.

Now I don’t know, what to do… It boots only if I install OpenWrt…

I need your help. What should I do?

Best regards

Please use the latest USB burning tool and then flash Android but remember to select erase all instead of normal.
This should erase everything in the emmc and flash Android.
Hope this way you will have Android. Coz flashing armbian will kill the emmc boot coz armbian doesn’t have a uboot on its own.

Try and let me know.

if your emmc was blanked not all sd images can be started!

(ubuntu mainline, openwrt, krescue images can boot from sd with blanked emmc )

just start krescue and write uboot too emmc (this one minimal bootload for emmc -> which can help next boot from sd for system which cant boot without emmc - for example armbian )

ant try start armbian from sd

another variant u can write any os back to emmc


I am using the version V2.2.0. Is there a newer version?. I erased every thing. and the usb tool writes many times, untill i pulled the usb cable up…

Hi hyphop,

ich tried almost with all OS… Debian, Manjaro, Ubuntu,CoreElec… the result is the same (i can only see either the boot logo , or some kernel messages (OK…), or blank screen )…

It is working only with OpenWRT, i don’t know exactly why , but i think , it is very small os , it uses only 998MB from emmc…

best regards

something wrong but what ?
u tell me openwrt start from emmc without problem

openwrt - this os for headless usage - like server or router etc

if krescue installation complited - installed images must works - but u have another situation - really strange

plz check all installation process must complited by OK message

if u have uart and can get some log errors from console it can help me

PS: if u have same problems with amlogic_burn too - looks like emmc broken or something other hw part

u can help me if provide some info

  1. start krescue
  2. full emmc erase
  3. goto shell
  4. md5sum /dev/mmcblk2
  5. wait about 5min and write output
  6. i can compare your result

I run md5sum and the output was

After formatting i installed debian9.mainline5.5.x.emmc but the result was the same, it was only black screen and two leds were on, red and white.

Any help or suggestions, what can be wrong?

I will try help u later may be today

Any help or suggestions, what can be wrong?

Plz write last krescue and check emmc by read writes

  • Main menu - test and checks - emmc check

PS: write me about results

Hi hyphop,

i tried with the new version of krescue… the result of bad block checking was ok. it took about 50min. I opened the file \tmp\badblocks.log with vi and there was no entry… I think so is ok.

i noticed during writing an image to emmc the red led was on… Is it default behavior?

1 Like

Can anyone help me? Is my device broken? What is wrong? I tried again with the usb tool. The result is the same, i see only the boot logo. How can I send it back for repairing?


it looks like something with voltage.

what is your power supply?


emmc looks like OK :wink:

  1. check try other power-cable + power adapter
  2. try check up ubuntu or debian server images
1 Like

I checked the power adapter, now I have a new one, it is working well…

Thanks for your help
Best regards

1 Like