Vim3 Pro / Android / Generic touch drivers

After a great success getting USB GPS working with the newest VIM3 official build, I have one last issue to tackle before I finalize my Vim3 install in my car. I am currently using an old Pioneer AppRadio with AppRadio Unchained Reloaded and cannot get the touch drivers to load. In the developer’s thread at XDA, a person posted a similar issue and I have tried the troubleshooting that the dev recommended, but it is still not working.

From the XDA thread:

Can you check that a file called ‘Generic.kl’ exists on your system?
It should be in one of the following directories:


Maybe in some cases not all drivers are loaded properly?
I think it’s uinput.ko.

I know that @Archangel1235 has done some magic with touch drivers on the linux side, but I was wondering if anyone had any ideas to help me solve this issue on the android side of the fence.

Any help would be greatly appreciated.

Maybe @davemf might know something, wait for him to respond…

Yes, he deals with Android for auto

I don’t understand. What does not work? USB touch screen?

1 Like

I understand that he has his own software that does not work correctly, maybe he’d better try your software

I think you need to compile the drivers for usb Touch screen I think its named usbtouchscreen.ko

and just load the module during bootup

1 Like

What does not work? USB touch screen?

Yes that’s right…apparently the app needs uinput.ko ton be loaded for it to work properly

Ok I’ll start trying to research that too.

You can try my ROM


I will give it a shot and report back - thank you!