VIM3 NVME NOT present

Which Khadas SBC do you use?

VIM3 pro

Which system do you use? Android, Ubuntu, OOWOW or others?

Ubuntu 20.04

Which version of system do you use? Khadas official images, self built images, or others?

khadas official image with kernal 5.15.119

Please describe your issue below:

I have a VIM3 pro board with the M.2 expansion board installed. On the M.2 expansion, I have a Samsung 990 EVO 1 TB NVME SSD installed. I have everything wired up as correctly as possible, the NVME is initialized and formatted as exFAT, and yet the board is not registering the drive at all. The steps I have checked and done so far include:

-lspci -vv returns nothing
-set usb_pcie_switchport to value 1
-any variation of nvme0n1 doesn’t exist within /dev

-dmesg | grep -i pci returns this output:

any help moving forward would be awesome

Heads up for anyone who comes across this:

While waiting for a reply to this thread, I was going go down the road of spinning up Krescue and seeing if I could do anything from there. I burned an image of Krescue to a microSD card, inserted the card, and then tried to reboot the VIM3 from MASKROM mode. The VIM3 did NOT boot from the SD card at first so I attempted to boot into upgrade once more and still nothing. It just booted to the 20.04 OS like normal. I logged in and went to check if the SD card even reads that its mounted and lo and behold, my NVME is there and awaiting to be formatted properly. I have no idea what I’ve just done but it’s working and some amount of elaboration would still be phenomenal lol

Hi @lcollante
Try this firmware:

Some 5.15 kernel firmware may have these problems and will be fixed in the next firmware update.

@willow Hi there,
Thank you for your help. I have the NVME installed on the VIM3 Pro. I have it initialized, the VIM3 sees it, and I have it formatted just as a mounted storage drive. I would like to have it be the primary storage and root file system for the entire OS. In other words, I would like everything to boot from the NVMe instead of the eMMC.
every route I’ve gone down to make this happened has not worked.

We just fixed this issue, we will double check on our side, and then provide you a solution. please followup.


1.Click to get firmware
2.Burn this firmware to SD card

3.Install sd card and ssd to VIM3 and Power-on
4.Copy sd card firmware to ssd

$ sudo emmc-install

5.Remove sd card and reboot
6.Check whether /dev/nvme0n1p1 is mounted on /

$ mount | grep ext4 I burned that image to an SD card, mounted it, and the VIM3 board booted from that SD card. Beforehand, I could not get the VIM3 to boot from anything else.

Later, I tried copying the firmware to the SSD but no amount of file permissions change or ownership changes would allow me to copy the firmware.

So, instead, I took that image you provided me and just burned it directly to the NVMe and reinstalled the SSD to the VIM3. Now the VIM3 is officially booting from the NVMe. So far everything appears to be working: applications are opening like they should be, things are downloading fine, etc.

I do not know if I have truly fixed this issue, but I am now booting from the NVMe and that is the next step I needed to figure out. Thank you

This should be the same as using sudo emmc-install to write image to SSD.

After system bootup, just check whether rootfs is mounted on NVMe SSD, if it is, then it is ok.

df -h