VIM3: Not powering ON

My VIM3 pro version is not getting powered on.
I have not used it for some time like three four months and powered on today. It worked as usual.
I downloaded and install manjaro 20.12 version in USB and Booted in VIM3
Then I installed manjaro 20.12 onto EMMC using the manjaro-arm-installer and shutdown the system.

I removed the USB and tried to power on. But it is not getting powered on. There is no LED glowing
Please help me fix this issue

Hi, check the power supply and the cable to it, it is better to replace and check immediately.

@rmariappan1988 Did you know how to use serial tool ? Or can you try to use burn tool to reburn a android image or a ubuntu image ?

Thanks @Vladimir.v.v and @Frank

I tried different power suppy and cable. Still the same.
When I connect the USB to the PC, it detects as follows:

Bus 003 Device 002: ID 1b8e:c003 Amlogic, Inc. GX-CHIP

So I hope the board has not gone bad. I currently don’t have my home win PC ready, that is the reason I try to bring this up after a long time. I only have arch linux in my work laptop. Last time I checked I was not able to install the burn tools correctly in arch linux.

I will test in two days and report back.

@Frank I somehow managed to boot my home pc and install the burning tool. VIM3 also got detected in the burn tool. But when I select the image, it throws the following error:

Parse burning image fail

These are the images I tried after extracting it:

Is this normal ? Can I uncheck ‘CheckImg’ option in File, and burn ? Or should I download different images ?

These images if for krescue.
Please use krescue to install such images.

Thanks @numbqq
Wow. Krescue is a miracle. Rescued my system. Able to install Manjaro to the emmc

Is it possible to install this Krescue to the spi flash and boot it when required ?

Also I am facing two more problems

  • htop only show two cores
  • WiFI not detected in manjaro image

Any solutions ?

Yes, it is. But suggest you to try to boot from SD card first.

Really? Which image ? Maybe you can try to install manjaro via krescue and check again.

Its the manjaro image installed from Krescue only. This one:

Please find the attached image for the cpu reference

Do you want me to install it again ?

No need to reinstall again.

Hello @Spikerguy Do you have any suggestion?

@rmariappan1988 from the CPU part number its clear that both cores are from the small cluster (2x A53 cores)

maybe the bigger cores aren’t appearing online, try this perhaps

sudo sh -c "echo 0 > /sys/devices/system/cpu/cpu3/online"

@Electr1 I tried the command you suggested. Still the same.

I did cat of online status of all the cpus.

cpu0/online - 1
cpu1/online - 1
cpu2/online - 0
cpu3/online - 0

I also tried writing 1 to cpu3 and got this error:

sh: line 0: echo: write error: Invalid argument

Also only 4 cpus are visible. It should be 6 right?
Any pointers on how to debug more

I tried the usualy trick of reinstalling different image. this time its the manjaro KDE version
And it working fine now.

Thanks everyone for the help

1 Like