VIM3 HDMI stopped working

Hi,

I accidently wired something wrong on the gpio pins of my VIM3 and 12V got through the board for a second. I can still communicate with the device over USB and use adb commands, only HDMI is not working. The cable and display are working on other devices and were working before the incidence on the VIM3. I tried to diagnose the board myself but haven’t found anything obviously wrong. I have access to a rework station and could desolder and solder resistors and capacitors, if anyone knows which component is most likely damaged.

Any help would be very much appreciated.

Hello, Schematics for all VIM3 versions can be found here.

Yeah I already tried to diagnose using the schematics, but thank you. (Didn’t know that the v13 schematic also exists)

@3id_L if you accessed the GPIO, I would suggest, one point of failure is the GPIO expansion chip (highlighted here):

image

and since you complain about the HDMI port, which maybe @Frank could explain in detail about,

btw can you tell which specific pins you used during the time of misconnection ?

If I remember correctly pins 15,16,20,22,35 and 37. To give more details these pins where used by an ESP8266 and the ESP8266 was connected to 12V and got fried and this damaged my VIM3 in the process.

I tested that chip it looks fine

@3id_L and is the HDMI the only peripheral not working on the device ?
can you check wifi and other things ? if nothing is visible from above it could look like a damaged internal trace or internal SoC damage…

Khadas employs HDMI protection on the VIMs. Have you checked it? Refer to page 10 of the schematic.

Otherwise you will have to trace back from SoC to HDMI output connector. Could get complicated, but if you have some good test equipment you might discover what component(s) were damaged.

Hi, judging by what you described, the diode to protect the HDMI port could have burned out, most likely the HDMI port itself is alive. You need to visually, very carefully inspect the board for damaged electronic components, also use the tester for more detailed information, make troubleshooting on your own …

Wifi works fine and the USB connectors work also.

I checked the voltage on D34 and D36 and I got 40-60mV on all HDMI_TX Pins except on HDMI_TX0N and HDMI_TX0P there I got 3.3V

If you mean D40 I checked that too it seems to work fine.

Update your firmware.

Updated to VIM3_Pie_V210128 still nothing

How do you update ,with UBT?

Yes exactly on Windows, I have another VIM3 which I flashed like that and it works fine