VIM3 : hang on starting kernel... on SD card


I’m trying to install my VIM3 with the ubuntu image. I’ve burned the img file to my SD card and i’m trying to boot with it but the VIM3 tells me “starting kernel…” and nothing happens after that…
Any ideas ?
You can find the output in the attachment.

I’m using the image VIM3_Ubuntu-server-focal_Linux-4.9_arm64_SD-USB_V0.9.7-201126.img
I’ve tried with this one too : VIM3_Ubuntu-server-focal_Linux-4.9_arm64_SD-USB_V0.9-20200530.img

Without success and with the same message.

@pea13 what do you run have in the eMMC ?

My EMMC is empty so nothing

install android in eMMC and check

that wouldn’t be needed, the linux firmware image already has a bootloader,
not sure why you need android in the eMMC…

It’s not entirely clear why keep eMMC empty, but some of the users talked about solving the problem in this way.

can you link to any other issue thread like this ?

I have solved this issue by installing directly Ubuntu on the EMMC with the burning tools .
I still don’t know why booting on the SD-CARD didn’t work :frowning:

Perhaps the problem is with the sd card itself, have you tried changing it?

@pea13 I just cross checked the error logs you have posted,
the issue is practically the same as what I have faced before, the issue subsides within a fault with the uboot itself, try using the latest image with the updated bootloader

here is a image made very recently, it works perfectly on a SD/USB disk

remember when using a BSP (4.9 kernel) image, the eMMC should have either android or mainline linux,

it won’t boot if there is 4.9 image in the eMMC

it seems your post

In his case, something else, he loaded, but the initialization did not go through completely, so another problem is most likely.

@Vladimir.v.v when I mean another post, I meant one where the eMMC was empty and the image wasn’t booting,
in my case scenario, the error happened even when eMMC was loaded with android, and the linux image was directly flashed to the eMMC,

so no, its not the same scenario :slightly_smiling_face:

1 Like

yes, I noticed that a slightly different problem, however, I assumed that it might help, everything is fine.

So everything is working fine. Thank you for your help :slight_smile: