VIM3 Flash image error

Which Khadas SBC do you use?


Which system do you use? Android, Ubuntu, OOWOW or others?

Ubuntu 20.04

Which version of system do you use? Khadas official images, self built images, or others?

Khadas official 20.04, emmc flash using amlogic burning tool

Please describe your issue below:


Please find an image of the error received when flashed:

Can you please let me know why it occurs and how I can fix it.

Thank you

Hello @Balaji

Please try to use another USB cable or USB host to try again.

Tried the following:

  1. A different USB cable and port
  2. reinstalled and downloaded the image and the burning tool again
  3. Powered the SBC using 12V molex connector

Still received the same error and no 100% green success message. Please see the image attached above.

Tried using Etcher to load an image onto a SD card and powered up the SBC, no boot

got the following error, attached is the serial console log:

May I please know what is the next step required to make the SBC boot from SD card instead of emmc once the image is flashed onto the SD card.

Thank you.

Just write the SD image to SD card and insert the card to board and power on then it will boot from the SD card.

HI There,
Thanks for response .My emmc is corrupted or doesnt have a full OS so i am trying to boot from sd card.Here is what I am doing.
I have downloaded sd image from link
wrote it to sd card using etcher
connected usb to serial connector to check the log
inserted in sd card slot and booted .
But its not booting , it is trying to load initramfs image and gets stuck at line
hctos: unable to read the hw clock as shown in above pic and just hangs there

also do i need to press any button (FUNCTION) to force boot it from sd card or it just checks mmc first if it doesnt find an image there then checks sd card ?


It does not need to press any button (function) to force boot it from the sd card.

I just checked it and it works.The following firmware is recommended to try again. Leave a comment if you have any questions
please click:

The above image linux-6.0 doesnt work, tried 5.18 , it doesnt work either
only 4.9 works on vim3 board