Vim3 fastboot stuck at logo

I’m following the how to use fastboot tutorial. After running the first command adb reboot fastboot the board reboots and is stuck on the logo. And the second command fastboot flashing unlock outputs < waiting for any device >.

Can anyone help?

Thanks

Hello! what do you currently have on eMMC?

Hi, it’s running android OS. I haven’t flashed anything yet.

Are you running Windows or Ubuntu?

I’m running Ubuntu 18.04

Okay, you need to contact Terry, include his name in your message, precede the name with the “@” symbol.

Good luck to you!

@root_ally are you trying to flash AOSP image ?

I am able to unlock the device with fastboot flashing unlock quickly after rebooting with adb reboot fastboot 4-5 seconds after entering the command (I used my windows PC) try to do it without connecting to the display maybe

1 Like

Thanks, that worked!

3 Likes

please mark solution and close topic,
stay safe & good day!

1 Like

FAILED (remote: locked device)
I am getting same issue it not unlock boot

@Pradeep_Kumar_Upadhy Can you provide complete process information of executing command?

I was flashing vim3l board using fastboot mode through usb-c How To Use Fastboot | Khadas Documentation where first start with
adb reboot fastboot
fastboot flashing unlock_critical
fastboot flashing unlock
fastboot flash bootloader bootloader.img
fastboot flash bootloader-boot0 bootloader.img
fastboot flash bootloader-boot1 bootloader.img
fastboot erase env
fastboot reboot-bootloader
sleep 5
fastboot flashing unlock_critical
fastboot flashing unlock
fastboot flash dts dt.img
fastboot flash dtbo dtbo.img
fastboot -w
fastboot erase param
fastboot erase tee
fastboot flash vbmeta vbmeta.img
fastboot flash odm odm.img
fastboot flash logo logo.img
fastboot flash boot boot.img
fastboot flash system system.img
fastboot flash vendor vendor.img
fastboot flash recovery recovery.img
fastboot flash product product.img
fastboot flashing lock_critical
fastboot flashing lock
fastboot reboot

then i get output
finished. total time: 0.031s
rebooting into bootloader…
OKAY [ 0.006s]
finished. total time: 3.015s

FAILED (command write failed (Protocol error))
finished. total time: 0.000s

Then black screen nothing is displaying and not coming in fastboot mode.

@Pradeep_Kumar_Upadhy The information you provided is a bit of a mess. Roughly speaking, you didn’t follow the operation mentioned in the document.

1 Like

So how can i recover board which is not working and how to flash my source code img in the board.

So how can i recover board which is not working and how to flash my source code img in the board.