Vim3 constant video artifacts when Nvme is mounted

Which Khadas SBC do you use?

I am using a new VIM3 Basic Amlogic A311D

Which system do you use? Android, Ubuntu, OOWOW or others?

I am using Ubuntu 20.04

Which version of system do you use? Khadas official images, self built images, or others?


Please describe your issue below:

My display is showing display issues similar to the ones showing in another thread. The visual issue happens when my SAMSUNG 970 EVO SSD is mounted/selected in Linux. I have tried multiple different power plugs and outlets to try my best to eliminate power issues that I saw referenced in other posts.

This is my first Khadas device so I am sorry if I have missed something simple.

We have several under test that are running NVMe and do not have that issue.

Have you tried a different USB cable, some of them are cheap and have small diameter wires for the power.

Make sure the NVMe heatsink bracket is not shorting out a couple of parts on the adapter board.

How are you mounting the drive?

Check your hdmi cable and possibly verify settings in your monitor / vim

Can you post a pic of your setup?

I have used 4 different USB C cables of different make with 3 different adapters (15W, 18W).
I reseated the heatsink and M2 Expansion adapter and made sure separation was kept (using thermal pads) to try and keep possible shorting points to a minimum.
I have also used 3 different monitor (4k, 1920x1080, and another basic 1080p) and tried 3 different HDMIs with each.
The visual issue is present on all combinations that I have tried. The issue will stop immediately if I select to unmount the drive through the GUI or cmdline, and starts again if remounted.


I think I actually figured it out. Feel kinda dumb :sweat_smile:.
I believe the issue was that I was still using the USB port that is shared with the PCIE. The visual impairment happened for a few seconds after unplugging the peripheral from that port, but it now seems to be working ok.
I will update if the visual starts to mess up again in the same way now that I am no longer using that port.


You are not alone. Glad you found the problem.