Vim3 boot loop when using own power

Which Khadas SBC do you use?


Which system do you use? Android, Ubuntu, OOWOW or others?


Which version of system do you use? Khadas official images, self built images, or others?


Please describe your issue below:

I had a power failure recently, and since then, my Vim3 just goes into a boot loop where it’ll briefly display the Khadas logo and then reboot. This is the same behaviour when booting off eMMC, or attempting to boot KRescue off microSD.

However, it’ll boot off both the eMMC and microSD just fine if it’s plugged into a computer.

I’ve tried rewriting a fresh OS image to the eMMC, but the behaviour persists.

Boot mode is set to eMMC as confirmed by kbi status.

Seems strange that it’d boot when connected to a computer (Macbook in my case) but not when running off its own power (I’ve tried multiple USB-c power adapters, including the stonking big 96W adapters that ship with the older Intel Macbooks).

Pulling my hair out over this one and would love some advice.


Hello @f00stx

1.The situation is caused by insufficient power supply, please choose a suitable adapter.
2.You can do a test to see if the HDMI can start normally after unplugging it.

Thanks for the reply.

Interestingly enough, I got it working with a 29W Apple USB-C adapter, but it does the boot loop thing with the bigger adapters (as big as 96W). Maybe it’s just a specific power profile that the bigger adapters don’t provide? Anyway, it seems to be working now.