VIM3 BASIC Ethernet speed problem

I already asked this problem 4 days ago

but I couldn’t get any solution

please help me

@mokuzin Maybe you can try with the lastest android ? This version has some patches for the main control chip added .

https://dl.khadas.com/Firmware/VIM3/Android/VIM3_Pie_V200319.7z

the problem is I don’t need android OS , I just need linux server OS for VIM3 BASIC

could you give me patches for linux firmware?

im not sure about your problem !!! maybe its hardware defect ?

u can check any other linux distros with diff kernels
for example try same krescue - and check ethernet

if u still have same problem for all systems its must be hardware defect !

i tried on other linux distro like…
VIMx.Debian.9.stretch.server.kernel-5.5.X.mainline.emmc.kresq
VIM3x.COREELEC.9.2.2.emmc.kresq
VIM3_Ubuntu-server-bionic_Linux-4.9_arm64_EMMC_V20191231.7z

and I still get same problem…

if ether DL speed only about 3Mb for all distros (and if u sure your tests is correct ) its not software problem

PS: other suggestion try setup manualy diff speed 100 or 1000
via ethtool or miitool - may be u can get more usefull info about problem

The router can not give a restriction on this address?

I tested on direct connection without router

How are you doing with WiFi?

WIFI speed is good
there is no problem

well… I’ve got very interesting result…

I could get 100MBps when I set speed 100 via ethtool, but when I set speed 1000 then I got problem again …

here is test log

root@HomeAssistant:/home/mokuzin# ethtool -s eth0 speed 100 duplex full
root@HomeAssistant:/home/mokuzin# ethtool eth0
Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supported pause frame use: Symmetric Receive-only
Supports auto-negotiation: Yes
Supported FEC modes: Not reported
Advertised link modes: 100baseT/Full
Advertised pause frame use: Symmetric Receive-only
Advertised auto-negotiation: Yes
Advertised FEC modes: Not reported
Link partner advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Link partner advertised pause frame use: Symmetric Receive-only
Link partner advertised auto-negotiation: Yes
Link partner advertised FEC modes: Not reported
Speed: 100Mb/s
Duplex: Full
Port: MII
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: ug
Wake-on: d
Current message level: 0x0000003f (63)
drv probe link timer ifdown ifup
Link detected: yes

root@HomeAssistant:/home/mokuzin# iperf3 -c 192.168.1.252 -R
Connecting to host 192.168.1.252, port 5201
Reverse mode, remote host 192.168.1.252 is sending
[ 5] local 192.168.1.253 port 42574 connected to 192.168.1.252 port 5201
[ ID] Interval Transfer Bitrate
[ 5] 0.00-1.00 sec 11.2 MBytes 94.3 Mbits/sec
[ 5] 1.00-2.00 sec 11.2 MBytes 94.1 Mbits/sec
[ 5] 2.00-3.00 sec 11.2 MBytes 94.1 Mbits/sec
[ 5] 3.00-4.00 sec 11.2 MBytes 94.2 Mbits/sec
[ 5] 4.00-5.00 sec 11.2 MBytes 94.1 Mbits/sec
[ 5] 5.00-6.00 sec 11.2 MBytes 94.2 Mbits/sec
[ 5] 6.00-7.00 sec 11.2 MBytes 94.1 Mbits/sec
[ 5] 7.00-8.00 sec 11.2 MBytes 94.1 Mbits/sec
[ 5] 8.00-9.00 sec 11.2 MBytes 94.2 Mbits/sec
[ 5] 9.00-10.00 sec 11.2 MBytes 94.1 Mbits/sec


[ ID] Interval Transfer Bitrate
[ 5] 0.00-10.00 sec 114 MBytes 95.3 Mbits/sec sender
[ 5] 0.00-10.00 sec 112 MBytes 94.2 Mbits/sec receiver

root@HomeAssistant:/home/mokuzin# ethtool -s eth0 speed 1000 duplex full
root@HomeAssistant:/home/mokuzin# ethtool eth0
Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supported pause frame use: Symmetric Receive-only
Supports auto-negotiation: Yes
Supported FEC modes: Not reported
Advertised link modes: 1000baseT/Full
Advertised pause frame use: Symmetric Receive-only
Advertised auto-negotiation: Yes
Advertised FEC modes: Not reported
Link partner advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Link partner advertised pause frame use: Symmetric Receive-only
Link partner advertised auto-negotiation: Yes
Link partner advertised FEC modes: Not reported
Speed: 1000Mb/s
Duplex: Full
Port: MII
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: ug
Wake-on: d
Current message level: 0x0000003f (63)
drv probe link timer ifdown ifup
Link detected: yes
root@HomeAssistant:/home/mokuzin# iperf3 -c 192.168.1.252 -R
Connecting to host 192.168.1.252, port 5201
Reverse mode, remote host 192.168.1.252 is sending
[ 5] local 192.168.1.253 port 42578 connected to 192.168.1.252 port 5201
[ ID] Interval Transfer Bitrate
[ 5] 0.00-1.00 sec 1.41 KBytes 11.6 Kbits/sec
[ 5] 1.00-2.00 sec 25.5 KBytes 209 Kbits/sec
[ 5] 2.00-3.00 sec 1.16 KBytes 9.50 Kbits/sec
[ 5] 3.00-4.00 sec 0.00 Bytes 0.00 bits/sec
[ 5] 4.00-5.00 sec 0.00 Bytes 0.00 bits/sec
[ 5] 5.00-6.00 sec 0.00 Bytes 0.00 bits/sec
[ 5] 6.00-7.00 sec 0.00 Bytes 0.00 bits/sec
[ 5] 7.00-8.00 sec 0.00 Bytes 0.00 bits/sec
[ 5] 8.00-9.00 sec 0.00 Bytes 0.00 bits/sec
[ 5] 9.00-10.00 sec 0.00 Bytes 0.00 bits/sec


[ ID] Interval Transfer Bitrate
[ 5] 0.00-10.00 sec 155 KBytes 127 Kbits/sec sender
[ 5] 0.00-10.00 sec 28.1 KBytes 23.0 Kbits/sec receiver

@mokuzin Brun with the lastest android just for check that this is you problem ior not . Beucase it work fine in my board .

so do u mean my board has problem??

@mokuzin I’m not sure, so I need you to cooperate in the test, so that we can solve your problem as soon as possible

some cable have problem for 1G
need real cat 5e cat6 cables
some times its a problem just for two points

another pairs can works without problems on 1G speed

i have see same problem many times

my lan cable has no problem
I tested another SBC with same cable