VIM3 Android Pie V191122 Preview ROM Release

Here release VIM3 Android Pie Preview ROM

Check Firmware Page to download the ROM.

ROM Infos:

  • ROM version: VIM3_Pie_V191122.7z
  • MD5SUM: e6ae4b88269911babbeeff1af97e15f3
  • The ROM is for EMMC installation only

Change Log

  • add dual display support
  • add TS050 touch panel support
  • add lcd backlight control menu
  • disable network captive portal check
  • change display density from 240 to 280
  • update amlogic sdk source code from p-amlogic_openlinux-20190720_aosp.xml to p-amlogic-openlinux-20191101-ott-aosp.xml

Known Issues

  • Navigation and Status bar issue
  • No Gsensor support

Upgrade guidance:

Tips for CoreELEC users:

As the Android ROM and CoreELEC used different version U-Boot on VIM3, and you have to edit config.ini file to solve the green screen issue:


CoreELEC team will update the Linux kernel in the future, and you don’t need to edit it manually then.

Have fun!


Good day, Terry. Antutu test in your latest firmware
VIM3_Pie_V191122 showed 121000 points, this result is less than in the previous version of VIM3_Pie_V191101 - 137000.
Can you fix this in the next version of your firmware?11 22

1 Like

Greetings. I noticed that only the first version 190809 of the firmware supported voice search from the remote control (in my case g10s) and in all subsequent versions (190907-191122) the voice search from the remote does not work. Accordingly, in the firmware from SuperCeleron the same situation. Can you tell me when this functionality will be restored?


I am trying the Mainline Kernel 5.4.0 on Manjaro Built and I am getting green screen issue.
What do I have to change to make it work? I tried adding use_rgb_to_yuv=1 to uEnv.ini but it doesn’t help.

Please advice.

The u-boot is verdor version or mainline version?

Preview ROM feedback…
At Settings/Display/ Screen position Zoom in/Zoom out has no effect.

Thanks for your feedback, I will check it.


Thanks for your feedback, I will check it.


Did you use BT remote with mic? You can install google Search application from Google play store by yourself.

Hi, Terry, I heard that there are problems for HDR10+, on Android 9, and it seems like Android 10 should solve it, can you clarify this question for me? thanks! Now I’m manually switching.
it will be a good replacement for Dolby vision.

The remote control is not Bluetooth but via a usb dongle 2.4GHz with voice button (model: vontar G10s). I tried to put Google search, Google assistant, GBoard keyboard but nothing helps. Does this happen because the Voice Mach button is blocked in the Google search settings?

Hi Sorry for late reply.

We are using this one. I guess it is very old as advices by balbes.
Please advice where can I find the latest one.


Navigation and Status bar can be closed???


No, and no one knows when this function will be done in firmware

I can’t st my location. It will not allow me to change it to “on”

So the picture still be cut when using streaming app :rofl:, pretty funny for a media use sbc :+1:.

1 Like

Hi all, after upgrading to V191122 my bluetooth speakers are undiscoverable - I’ve tried Sony and JBL so far and the board just keeps searching and didn’t find any bluetooth device, despite they are in pairing mode. Any of you have similar experience? (In V191101 release no problem at all, connected instantly) Thank you