Vim1 usbA ports stopped working!

Hi, my good old vim1pro does not recognize any of my USB mice or, usb keyboards anymore.
Any good advice to diagnose what went wrong and eventually how to fix that ?

hi, only peripherals or how usb drives are not visible either? well, one way to check is with a complete reinstallation of the system, or another system.
If you can remember after what the problem started?

You can of course provide a serial debug log.

another option is the failure of the power supply / power supply cable.

If two ports fail…

Same problem with vim1 if all else fails.
Good luck!

1 Like

System booted from emmc as well as system booted from sdcard both cannot see my hid peripherals…the event seemed to be when I removed my rj45 cable and the board suddenly rebooted then…

It is quite awful to hear your plight…,
did you try checking if the ports have any physical wear down ?

More probable is, maybe something pulled a little too much current and fried the circuits ?, perhaps ESD played foul here ?, Did you check the USB ports on the GPIO ?

1 Like

The most curious thing, rj45 is alive! try to visually inspect the board, you may see something

Visual inspection shows nothing weird sofar

in particular is this component ok, controller FE8.1? Then there is probably a chance the hardware is alive!

Well, you ought to be scolded for hot-plugging that Ethernet cable…
but since you are suffering from a painful loss I won’t… :triumph:

You can’t visually “see” internal damage, do you have a multimeter ?
Try checking the electrical contacts, is there power in the USB ports ?

i tried to plug unifying usb dongle and an usb thumb drive, then typed lsusb

but nothing shows except
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

and dmesg is dead silent upon insertion of the usb devices
I also changed the power supply, that did change nothing

rj45 cable is hot pluggable on that board (and on all boards), nothing out of the ordinary

1 Like

i have found no way to test if gpio usb is working or not

it is better to replace the cable too

I wouldn’t recommend it…
My pops has seen a few PLC’s blow up like that…
poof !, and those things aren’t cheap btw…

Just thinking and pondering on, shouldn’t there be 3 devices connected to the USB by default…?
something like Terminus Technology or something… I think you blew the Internal USB Hub mate…

do you suggest not touching vim at all? nonsense, anyone can do it in any given situation

tried another power supplly cable, to no result.
it seems that this is the end of my board, and my love with khadas sbcs, not sure i want to invest in any other vim for now

@ravelo did you verify my point ?

That there is 3 USB devices by default…
and that something has happened to the USB hub ?

otherwise you should get Terminus technology along with the other 2 “Linux Foundation x root hub”, in the output of lsusb…

we know there are 3 usb available, this is a fact, but i m not able to test the 3rd one, and the 2 first are definitely out of order,
i still can use the board, typing from a BT kbd+trackpad, but the ux is terrible…

no physical weardown whatsoever

Let’s just see if the khadas team can tell you something,
But my opinion is that the internal USB hub has taken damage or is not functioning…

I’m sure we can have this sorted out, so don’t worry…

when i plugged in a 4 port unpowered usb hub, the board rebooted!
but then it started “normally” and the hub light is on, so i assume that +5V is getting the the usb-a sockets! but lsusb does not list that external hub