VIM1 编译Ubuntu失败Unsupported ioctl: cmd=0x5331

#1

编译的选项如下,报错如下图:
PARAMETERS*
Fenix Version: 0.6
Khadas Board: VIM1
Uboot Version: 2015.01
Uboot Configuration: kvim_defconfig
Uboot Branch: khadas-vim-v2015.01
Linux Version: 3.14
Linux Configuration: kvim_defconfig
Linux DTB: arch/arm64/boot/dts/kvim_linux.dtb
Linux Branch: khadas-vim-3.14.y
Distribution: Ubuntu
Distribution Release: xenial
Distribution Type: xfce
Distribution Arch: arm64
Install Type: EMMC
Final Image: VIM1_Ubuntu-xfce-xenial_Linux-3.14_arm64_EMMC_V20190507.img


0 Likes

#2

Hello waterman,

你用的是什么系统?系统版本?是本地编译还是在docker下?

这个问题还没定位到具体原因,好像编译Ubuntu 16.04时会出现,你可以试试编译ubuntu 18.04 bionic。

0 Likes

#3

用的就是Ubuntu 16.04.1编译的,好的,再试一下ubuntu 18.04 bionic

0 Likes

#4

你的host PC 系统版本呢?是否是在docker下编译? 这个问题我之前碰到过一次,后来打了针对这个问题的补丁后,我自己的电脑就没重现过了,现在你那边出现了,想了解下你的编译环境,看看能否定位这个问题。

0 Likes

#5

host pc win10上面安装的virtualbox虚拟机,虚拟机中安装的ubuntu 16.04编译环境

0 Likes