VIM1 powers on but No Display or UART Output


I had the Device on inside the case which comes along with it. Heatsink on top and bottom in place and it was working fine. I was in Uboot. then after few mins no response from uart and no display also.

Now it will power on but no display on hdmi and nothing on UART. All it does is heat up under the CPU are if I keep it on for more than a min it will get super hot.

Just found out a new thing about this situation, When I connect uart from pc to device then the windows would crash blue screen of death. If I remove it I can use the PC without any issue. I am not really sure if its the device pulling to much power? AFAIK uart should power isnt connected to the board, just RX, TX and GND.

I tried M-Register to check If I can get it to upgrade mode but no luck.

I can confirm there is something short after I did this.
Just removed the heatsink to check how the CPU gets, I just connected the usb-c and within 2 seconds the cpu was super hot that I couldn’t touch it anymore. I think there is something short.


@kenny Please take a look at this issue. Thanks.

Hi Spikerguy
please help me to check:

  • Which power adapter do you use?
  • the heatsink is from our shop?
  • From your description, your VIM1 have a case and Heatsink.can you take some clear picture for me:
    • VIM1 with heatsink and case
    • VIM1 with heatsink but without case
    • VIM1 without heatsink and case, just a single board, need the bottom side and top side picture.
1 Like

I use the normal one 5v 1amp which I have been using for long time.

Yes the top one is khadas official heatsink first edition.

Yes I removed the case now just to check if there is any short but I dont see short or damage to the board.
I will get some pics for you in sometime.

Here are some images.

If you need any specific picture then please advice.

It seems that vim3 needs at least 5V2A

VIM1 It is and it should work fine with 1A as far as no USB Powered HDD’s are connected.

I have an RK3399BOX that used to work perfectly with 5V1A. Now it has to work with 5V2A.

Otherwise, it cannot enter the system.

I don’t know why, but you can try.

Thanks for the advice dear. I have tried already by connecting it to the computer, 1A and 2.1A power adaptors. As I have dual USB adaptor already.

Hi Spikerguy
sorry for the inconvenience.
I can’t see any problem at present. Could you take another close-up photo for me? thank’s.

and more question:

  • How long have you been buying this board?
  • Have you ever used any other adapters that exceed 5V voltage?

Purchased it in March 2019

No, I am an engineer and I know it will blow up if I do that. but 4 days ago I used vim3 khadas power supply official one and it is 5v/9v/12v so assuming it should negotiate first before delivering 9v to the device. The device red light started blinking so I removed it immediately and after that I used my phones normal charger 5v 1a and 2.1a and it was working fine but then after around 3days of using this happened.

If you want me to do a test with a multi meter then advice me on that. I can give you the readings.

Hi Spikerguy
thank you very much for your help.
If it’s convenient, please help me test these points with a multimeter.

  • Short circuit test(no power supply)
    is any points was short circuit to GND?(from point 1 to point 9)

  • Voltage measurement (if there is any points was short circuit above, do not power up to test voltage)
    what’s the voltage from point 1 to point 9?

    • Point 1 (DDR3_1.5V):
    • Point 2 (AO_5V):
    • Point 3 (VCC1.8V):
    • Point 4 (VDDIO_AO18):
    • Point 5 (VCCK):
    • Point 6 (VDD_EE):
    • Point 7 (VDDIO_AO3.3V):
    • Point 8 (VCC_MCU):
    • Point 9 (RX & TX):

thank’s again

Point 6 to GND and Point 7 to GND are short.


is a very bad news. please send it back to me to find out why. and we will send you a new one.
It’s early morning now. Tomorrow I’ll get my colleagues to contact you. thank’s for your help. sorry for the inconvenience.

Yes I understand its early morning, Thats the reason I replied to you instantly :stuck_out_tongue:

What could be the reason for this?

It’s not clear yet. When the board comes back, I will do more analysis to see if it is PCB or material problem. and will share to you.


Hi @Spikerguy

I will PM you the instructions, please note

thank you

1 Like

Hi Spikerguy
I have received the your VIM1 for some day. I found that the CPU(S905X) was broken which make the VDD_EE and VDDIO_AO3.3V short circuited. don’t know what caused this.

now, i replace a new CPU, and doing some test:

  • Short circuit test, is pass

  • Check all the voltage is correct, also the current is correct.

  • Do a full test, all function is pass.

  • Reboot aging test 12 hour, is pass.

  • play a 4k vedio test 4 hour, is pass

  • Use 24W power adapter to power on for one hour, the red led flashing, and the Input voltage will not exceed 5V. VIM1_V12 not support the 24W power adapter. after one hour, the CPU works well. it seems not the problem of 24W power adapter.

I don’t know why the CPU was broken at so far.

1 Like

Thank you for the reply.

I can say that the CPU never had any physical Damage as it was always covered with the heatsink.

This happened to me as soon as I try to power on from the new Khadas Official Power Adaptor 24W so I immediately removed it.

Did you see any physical damage to the CPU? As the last think it did was I tried to install manjaro on eMMC and was following the steps and it was stuck on boot screen, specially in uboot.

Can running it in uboot without proper firmware/os overheat it ?

sorry, I am not accurate in my description. I mean electrical broken, not physical broken on the surface. the CPU looks good on the surface.

can you send me the operation steps,it seems can not make CPU broken, but i want to have a try.