VIM1 - gpio export, write error: Invalid argument | status -22

Hi, I’m having a hard time exporting gpio pins on the Khadas Vim1, here is the error I am getting

# echo 430 > /sys/class/gpio/export
[   60.306648@3] meson-gxl-pinctrl pinctrl@4b0: request() failed for pin 29
[   60.307924@3] meson-gxl-pinctrl pinctrl@4b0: pin-29 (periphs-banks:430) status -22
-bash: echo: write error: Invalid argument

Tyring to get pins GPIOH_6/7/8/9, I can get pin GPIOH_5 to export properly, but the other four give the above error.
I see banks in my gpio folder as

# ls /sys/class/gpio/
export gpiochip401 gpiochip501 unexport

so I’ve been trying to get pins under the 401+pin number:

// all these give the invalid argument error
GPIOH_7 (pin 29) as # cat 430 > /sys/class/gpio/export
GPIOH_6 (pin 30) as # cat 431 > /sys/class/gpio/export
GPIOH_9 (pin 31) as # cat 432 > /sys/class/gpio/export
GPIOH_8 (pin 32) as # cat 433 > /sys/class/gpio/export

// only this is working
GPIOH_5 (pin 37) as # cat 438 > /sys/class/gpio/export

I’m using the ubuntu emmc image from Khadas.

vim1-ubuntu-18.04-server-linux-4.9-fenix-1.1.1-220725-emmc.img

This post mentioned in may be a jtag conflict

so I found the uboot arguments, but I’m not sure which argument to set to off.

jtagoff jtagoff [apao|apee|scpao|scpee]

here is where I found the arguments: GPIO export on Ubuntu is not working. What's the problem?

I set all 4 to off and tried that with no success

kvim#   jtagoff apao
kvim#   jtagoff apee
kvim#   jtagoff scpao
kvim#   jtagoff scpee
kvim#   saveenv
kvim#   reboot

I hope it’s a matter of incorrect pin numbers, becuase dealing with a software conflict will be hard to overcome, all help welcome

@firecrow8 Those pins use for I2S, if you need to use those as a export GPIO, you need to remove i2s in overlay and reboot.

thank you so much @Frank I will give that a try, I see it listed in the uboot command argument options