VIM1 does not render FHD

Hello Colleagues,

Regards from sunny Riga again and our best wishes to You all at todays challenging times!

We are more or less back on track and proceeding fast forward with integration of Your excellent SBCs into our digital signage systems.

Unfortunately we encountered new problem – appears that VIMs do not render FHD (1920x1080) resolution :smiley:. For illustration please find attached Picture1 with VIM1 Pro v12 with Nougat rendering of Your website (for example):

In the Picture2 there are the same render, but from the newer VIM1 Pro v14 with Pie = even worse :blush::

When pointing Chrome to simple device width detection image (Picture3) we see that VIM1 renders device width of 1280px (instead of actual screen width of 1920px):

Unfortunately change of Android Display resolution settings does nothing – with Iiyama monitor VIM1 even do not offer it higher than 720p (Picture4):

With Samsung and Philips monitors VIM1 offered possibility to select also 1080p, but it has no effect and after restart it is dropped down back to 720p.

It should be set somewhere deeper in the VIM1 machine. First thought coming into our mind was to find some setting in the β€œbuild.prop” directory. Still neither here nor in β€œdefault.prop” we did not found anything solving the problem.

Dear Colleagues – please be so kind to let us know how to proceed to get Your VIM devices to render actual FHD = 1920x1080px? Sorry to say – without FullHD – there are no digital signage possible :blush:.

Thank You very much in advance.

Valts from Latvia

Hello! and on what firmware is this observed?

Thank You Vladimir,

Sorry to say – I am not very sure if I understood right where to look for it, but what we find so far is following:
for VIM1 Pro v12:
in the β€œbuild.prop” – ro.product.firmware=00502001
in the Settings:About – Build: VIM_Nougat_20180619
for VIM1 Pro v14:
we cannot read β€œbuild.prop” – VIM does not allow any actions on it
in the Settings:About – Build: VIM_Pie_20190916

Is it what You asked for?
Should You need other or any additional info – please be so kind to ask – we will do our best.
Thank You.

all right! yes, tell me, is this the only firmware that you tried?
Yes, most importantly, do your monitors support Full HD?
and yet, adjusting the screen according to your photo, scroll to the end up and down, and you should see all the supported resolutions, good luck! :slightly_smiling_face:

Thank You Vladimir,

With VIM1 Pro v14 – Yes, it is in factory default state – actually we got this machine just yesterday.

With VIM1 Pro v12 – we installed this emmc image – VIM1.Android_Nougat_V180619.emmc.kresq – nicely mastered by Your colleague Hyphop for the purpose to remove startup logo. As much as I understand – it is producing new firmware, but I am really not sure about these matters.

Yes, of course – we use only FHD 1920x1080 monitors – Iiyama, Samsung, Philips, LG, DELL – All are FHD 1920x1080.

No, Vladimir – it is not the case.

Please – as I wrote in my initial request – β€œchange of Android Display resolution settings does nothing – with Iiyama monitor VIM1 even do not offer it higher than 720p (Picture4). With Samsung and Philips monitors VIM1 offered possibility to select also 1080p, but it has no effect and after restart it is dropped down back to 720p.”

I can just confirm it once again – changing of Display settings Screen resolution does absolutely Nothing.

It should be set somewhere else, somewhere deeper in the VIM1 machine.

But where?

Please – truly looking forward to Your help,


I’m up to Hyphop, like up to China :rofl::rofl::rofl:

I’m a simple user, I just have experience with android, I tried to help you :wink:
There is an alternative firmware from Superceleron, try installing it and checking.
as for the stock firmware, then you need to ask Terry

Thank You very much Vladimir,

Thank You for Your good will.

I review all You as top experts – You are – everybody in his/her own niche.

Thank You indeed.

Yes, please, we would much appreciate help from everybody.

Please, Terry, if You could tell us what to do – we would be really much Thankful.

With my very best regards,


1 Like

Dear Colleagues,

Regards from Riga again!

As much as we gathered info here and there – we tried some possibilities.
We added to the build.prop following code:
this made no effect.
Then additionally we changed also:
ro.sf.lcd_density from 240 to 160
This somehow produced needed digital signage behaviour – VIM1 displaying 1920x1080 – still sorry to say just on very few monitors. In addition this new code destroys the system bar – square button is lost completely, triangle and ring is outpositioned to the far left and in one case triangle is missing at all.

So this is not solution.

Dear Colleagues, please – we are really stuck in this problem.
Please be so kind to let us know – what do You think on this. How to proceed?
Thank You.

Truly looking forward to an info from You,
With my very best regards,


What’s the version of your system? Did you try to flash the new firmware VIM1_Pie_V200317 for your device?

Thank You Terry,

Yes, sure – all VIM1s we have v12 and v14 now have been flashed new Android 9 firmware.
Still, this wrong resolution defect is observed with both – either old and new firmwares.
On every monitor we have tested so far, being it FHD or 4K – all VIM1 units render just 1280x720.
You should be able to replicate this effect too. Just take Your VIM1 and try to surf the web. You should see for Yourself :smiley:.

Truly looking forward to any advice from You – just say – we will try to implement all Your suggestions.

Thank You.


Hello Terry & Colleagues,

Regards from Riga and Thank You for Your previous kind cooperation.

We are just wondering if there are still not any news about this problem.
Long time passed.
May be You can just let us know few short answers:
– Did You find the cause of the problem?
– Do You plan to ellaborate solution?
– If You have no time at present – When approximate could we expect it to happen?

Thank You very much.

Truly looking forward to Your help,
With my very best regards,

Valts Geidans