Vim v1.2 red light no console output

Can you please help me find out what could possibly happened?

I had a running armbian kiosk. Today I switched it from external USB modem to internal wifi connection. And it started to behave faulty. Like not playing videos and freezing.

So I shutted it down and took it home.
At home I decided to rewrite it with a fresh image.
I started parallels->windows with burning rom 2.1.2 running. And plugged vim usbc to my mac with my finger on vim’s Power button as I remembered it could bring it to upgrade mode instantly(looks like its not).

Vim just turned red light on and that’s it.
I tried to attach a serial console but nothing is there at all. Not a single line.

I tried resetting it with Reset button, Power+Reset, M-register mode with no luck.
Still red light and no console output.
What can be wrong?

Hi kkkkk:
When you power off, does your VIM device still have HDMI output?

For the serial console: kindly double check that the whether you correctly connect the Tx and Rx pins?

Good day!

Thank you! You were right - HDMI was working. I successfully went to update via M-register. Phew…