VIM 3L Ubuntu and VLC


I have the VIM 3L. I downloaded and flashed the image “VIM3L_Ubuntu-gnome-focal_Linux-4.9_arm64_EMMC_V0.9-20200530” for Ubuntu. So far everything went without any problems.
Then I installed the VLC player.

I recorded a video with the smartphone (4K, 30fps, acc).

I wanted to play this video with the VLC player. But instead of the video, I only saw a still image. I heard the sound but the picture didn’t move.

Are there any settings that have to be made so that the VIM 3L can play a 4K video with VLC?

many greetings René

if u need hardware accelerated for 4K video u must use CoreELEC - its works smoth

Android is also mildly good for video playback :slightly_smiling_face:
but of course Core-elec is the best for Media playback…


I’ve already tried Kodi. Going well.
For a test setup, I would need a player with which I can also change the resolution and other parameters. Hence my choice of the VLC player.


I tried to write coreelec to an sd card with etcher. but there is always an error message that the image has an error.

I use this path for the image

hi, use Rufus to write to SD card, archive for recording is on coreelec official website


i download coreelec from this site
I use Rufus to write to SD card. I put the card into VIM3L. But it is not booting.
For your info. I installt Ubuntu first on the VIM3L.
How i can start the VIMN3L from SD card? And how i can move the coreelec from SD Card zu internal flash?

Ubuntu on eMMC?
If Ubuntu is on the eMMC, then those SD card images won’t boot…
as boot order there is Power » eMMC » SD card

Krescue alone is able to boot, in such a case…

However, if you are able to flash a Mainline Linux image to the eMMC,
then the boot order would be Power » SD card » eMMC

Guten Tag!

i have check last baleno ethcer version - works fine

PS: i have one idea why its happens with your version - u can help me just post output error cmd - from C:\Users*balena*.cmd as writed on your screen :wink:
and i will try to help u

first i use the portable version. after your video i install the full version on pc. with this version i can write the image.
So the next problem is coming. How can i install the coreelec to emmc?

start krescue from sd and write coreeelec or any other system to emmc by online

if coreelec was started from sd must same have native emmc installer - but this ways have many other “if” and troubles …

make sure you have Android on ur emmc


thanks for your help.
i got the coreelec from the page i mentioned above (CoreELEC-Amlogic-ng.arm- I put it on the SD Card of the kresue SD Card and boot. But i cannot select it from the “image WRITE to …” menu.
Also there is no internet connection.

do you not have a active connection in your home ? or have you not connected to the network yet ?

you can either plugin an Ethernet cable to your router, or use the wifi functionality, baked into Krescue…

Use the instructions on docs.khadas or search the forum, there is enough information on this.

NO need download coreelec images , just start krescue with active internet connection!!! (if u dont have ethernet u can same setup wifi connection anytime )

( sure u can download image manually and put to kresue SD dump partition )