VIM 3 Pro won’t power

VIM 3 Pro

Today my VIM3 Pro would not power up anymore. It used to sit in suspense with the blue light flickering till I started a CEC chain and now it’s just dead.

I tested the 24W USB-C Adapter and cable I bought with it at the time with a mobile phone, and it works fine. Tried various other electricity sockets and chargers and nothing. Also tried connecting it to my PC with a USB-C (VIM) to USB-A (PC) cable as my PC is rather old and doesn’t have USB-C.

I’m using it with CoreELEC on eMMc.

Hope someone can help. I’m not very technical and it’s been a few years since I set it up.

Thanks in advance.

Hello @Moses_Hoopoe

So it does work with the 24w adapter but other power sources are not responsive enough to turn it on ?

1 Like

Sorry, I guess I wasn’t clear. The VIM does not work.

The 24W is the PSU I bought with it and used since. I tested it with mobile phone to see it’s still working and not the cause for the VIM issue.

Do you have a ttl adapter so you can monitor linux debug port?

It might be okay, just broken software. If it hangs in uboot you will not see any lights, so look at output on the debug port, if you see it reload a fresh image.


Thanks for your response.

I honestly don’t know what that is haha.

I’m not a typical SBC user and bought VIM solely for streaming purposes with CoreELEC as it seemed like a good alternative to more mass market products like NV Shield.
I quite dreaded needing to do the install part on my own and I can’t even remember how I did it! I must have had very very simple and easy to follow instructions at the time :slight_smile:

If it’s any indication, the device stays stone cold when hooked to electricity. Was always a bit warm when it showed the blue light.

@Moses_Hoopoe can you try connecting the vim3 to your PC and triple clicking the middle button?

This will put it in upgrade mode and maybe allow you to reinstall your firmware.

As I said I’m not an experienced user. I would require much more detailed instructions to do it.

Connect to PC with USB-C? Can I use adapter to USB-A as my PC does not have USB-C and I didn’t have one when I first installed before either.
Do I use instructions from here:
or here:
or something else?
I don’t need Android, only CoreELEC.

Hello @Moses_Hoopoe

follow this doc VIM3/3L Boot into Upgrade Mode [Khadas Docs]

This is not for installation, it’s just a way for us to know if the board is in working order or not.

Yes that won’t be an issue. we just need to know if the device can start up and appear as a connected usb device, we can see if something connects from the device manager of windows, or if linux/mac, just use lsusb command.

Here’s what I tried:

Connected VIM3 to PC with it’s USB-C cable (friend brought a laptop with USB-C sockets).

Then I tried:

  1. Pressed middle button 3 times - nothing happened.

  2. Inserted an SD Card with KRescue to VIM, connected to PC with USB-C. Pressed middle button 3 times. Nothing happened. I tried that without HDMI and with HDMI connected to my TV.

  3. Following a youtube video I also tried with an SD card with KR + holding power button + pressing middle button 3 times. Tried the same also with the SD card in a USB adapter connected to both USB-A ports on VIM 3. Nothing happened on all cases.

I’m not sure exactly what I was supposed to see if it went into Upgrade mode. Should a light have turned on?

Re: KRescue:
I could not find it here as the Khadas website/video shows: - Index of /firmware/
Instead I downloaded from here:
Releases · hyphop/khadas-rescue · GitHub

Just and update if anyone is interested.

Khadas support offered very generously to send the device back for repair even though it’s post warranty.
I since received it and it’s working well again. Apparently there was a broken capacitor on the device.

Kudos for the great support and service!

1 Like