Vim 3 is often freezing during any type of video playback


I am at my wits end trying to deduce why this is happening, maybe I’ll try to flash android just to see if this is also happening there. The freezes are random, and not linked to temperature as it never goes above 60 degrees.

My setup

Manjaro plasma latest updated. Lts kernel, mesa stable and mesaRC both tried
Happens more often in Wayland session but also happening on x11.

If I perform regular tasks like browsing or such, no problems. As soon as I play video in browser or vlc etc, maybe in 30 or 40 minutes it freezes and locks up. Power reset and then again after maybe 1 hour it freezes. I have even tried CPU governor’s and multiple video application like Kodi, smplayer, vlc

Also important to note vim3 blinking white led also stops blinking as soon as this happens

That sounds like a kernel panic.
I will have to remove all khadas patch and test them one by one…

You should move to linux-lts pkg or linux pkg

Test the same scenario with that kernel.

Let me know if it fixes the crash.


I am currently already using linuxLTS and i experienced same in linux khadas a while back too. Linux rc i didnt test in detail yet. Any way i can help you get some logs after such a freeze? The system locks up so i have to power cycle, does it retain anything after reboot? Last_kmsg or any thing sikilar to as adb logcat in android?

@Spikerguy I haven’t used the “linux” version yet, shall i try that too? And is this kind of behavior linked to kernel or mesa driver???

Sounds like a thermal issue.
How are you cooling the board?

I continuously monitor the board temp and it never goes above 55 or 60 deg C which is way lower than the thermal throttle limit. You need some logs as proof? Board hanging up should not be happening unless temperature exceed 70 to 80 degrees. It’s ambient idle temperature is 45 to 48 degrees at 0 CPU activity.

For your answer related to cooling

On top I have the official khadas passive heatsink, on bottom I have the khadas official metal plate bonded with thermal pad.


  1. Make sure all of the IC’s have thermal tape on them. Even though they are not hot to touch it is very important they are in full contact with the heatsink.
  2. Check that all the clear liner is removed from the thermal tape.
  3. Use a thinner piece of tape on the taller IC and thicker tape on all the others.
  4. Fan direction must be blowing air down and into the cooling fins
  5. This is the standard passive heatsink and fan is on top of the fins.

I know what the thermal limits say, however it all runs better and faster when it is cool.

1 Like

I understand you bro. But my device is not over heating at all. I have compiled applications and done other intensive tasks. This locking up only happens in video playback specifically.


yes try it please.

i will look into amlogic pending task soon in the coming week.

1 Like

“Linux” has no audio on vim3. I’m reverting to linux-lts for now.

Arghh i don’t understand why upstream keeps changing the audio nodes name and routing every time.

Right now only Linux lts gives me audio.

1 Like

Last 2 days I installed armbian on sdcard and ran from it. The device didn’t freeze in 2 days even one time. I ran videos, chromium YouTube 1080 and 720 and local files on vlc and Kodi etc. It was armbian focal using 5.10 kernel and mesa was 21 I think.

Today I again tried Manjaro plasma which was already on emmc and seemingly out of nowhere it crashed and froze while I was adding some widgets on desktop. Which made me wonder it is something specific to this Manjaro installation which I have done which could be the root cause.

I mostly don’t change many deep things, mesa is non-git, Linux is lts (yes lts also crashed) and the only custom change is that I was using schedutil governor. Maybe the CPU scaling crashes… Don’t know.

So want to ask you, which CPU governor you recommend most stable?

Also tell me if it could be plasma related, in which case I can try to switch to gnome or even mate/xfce. Because even though I love plasma, right now I want a stable non-crashing box… Thanks for all your time and support.

P. S audio issue is genuine and it persists, you told you are working on it.


For Shutdown and reboot issue it the the plymouth that fails.
So follow the steps from this post.

For audio you can continue using linux-khadas and audio will work.

If it is broken on linux package that means something changed on upstream source and for that I need time to look into.

For amlogic S922x boards performance mode which is already default on linux-khadas

I am using Kde Plasma on S922x board for testing and I dont’ have this issue unless you’re on unstable branch.

please switch to stable branch and use mesa only and not the git version.
There are many changes happening at upstream panfrost so its kinda breaking stuff. Nothing Manjaro specific though.

On Linux-khadas, audio is not working. It only works on Linux-lts. Did you update it or anything?

Ah right. Can you switch the audio routing in the to the other option ?

uncomment Old config and Comment out new config and reboot.

Good Luck.

Didn’t work. I did the changes and rebooted yet it fails to show audio device.

One strange thing. I recently installed Manjaro Mate from official website and fully updated it. It has Linux-khadas and somehow hdmi sound is working on it…… i dont know why its not working on plasma…. Is it due to pipewire/pulseaudio differences in both DEs or just something random?

Edit: HDMI audio is also not working on Manjaro Gnome out of the box with Linux-khadas. Don’t know what’s different in Manjaro Mate.

1 Like