Vim 3 Interrupt over GPIO (touch driver ft5x06)

Problem: touch driver does not start at boot.


Tried VIM3 && VIM3L


ubuntu lxde


tried kernel version 4.9, 6.0, 6.2.


Im currently stuck getting the touch driver to work with VIM3/VIM3L/VIM2/VIM1.

I allready tried multiple ubuntu images/versions and kernel versions (4.9-6.2).
Tried with fenix repo.
Tried downloading existing images.

I enabled the driver in the kernel-config ( device drivers → touchscreen → edt-ft5x06)
The driver is included in the kernel-version afterwards.

I tried changing the device-tree multiple times.
I even tried multiple dt-overlays to get this working.


Does anyone have a solution for my problem.
Or is able to provide a correct device-tree overlay/image for this driver (ft5x06) ?

Hello @Korbinian

What screen you used? The TS050 use touch IC ft5x06 and it should work with the 4.9 kernel images.

I would like to use a Newhaven-touch-display 7" over i2c
Product Specs sheet:

I am allready able to check the registers via ‘i2cget’.

But im not able to check them on a interrupt.

registercall write 0x70 .
registercall read 0x02 . to get the touchpoints as test data