VIM 2 not able detect to flash new image

Hi All,

My device keep on showing Android Boot screen so I have tried to flash the image following the instruction upgrade via usbcable but the device is not detected by the usb burning tool.

I would like to flash the new image.

Best Regards

Hi, Amoon:
Can you kindly list the detailed steps you did to upgrade the new image, so we can figure out a wrong operation you might did. :wink:


Hi Gouwa,

1 download the image from Firwmare Resource VIM2_Nougat_V170831.7z and extracted the image.
2 Download the Usb download tools install the setup.
3 Select the image to be upgraded from the path.
4 Connected the VIM2 board via USB type C cable.
4a Long press Power key without release.
4b Short press Reset key and release.
4c Count 2-3 seconds and release the Power key to enter into upgrade mode.

But the device is not detected by the USB download tools.

Is their any alternate way to fix this issue.
On my TV screen it shows Android boot logo nothing moving ahead.

best regards

Hi, Amoon:
Which Windows OS you installed on your PC? You might need to run the USB Tool as Administrator.

And can you try again to hold the Power button longer time like 3-5 secs.

Yep, you can also try the SD Card approach to upgrade for VIMs.

Confirm with you again:
Which follow is the Android boot logo you mentioned:

  • Khadas Logo
  • Android Bootanimation Logo?

First few boot were fine but when I installed few apps and rebooted the device it’s not boot up.

Yes started USB device with Administrative privileges.
I have Windows 10, And on my TV it shows,
Khadas Logo
Android Bootanimation Logo?

but nothing moves ahead.

I will give the try for sdcard install and let you know if this is a success.

best regards

It should be issues in windows PC side, may be you can try to reinstall the USB tools or just try the sd card approach

Hi, did you get the problem sorted? What worked for me was open usb burning tool, select .img file, plug usb type c into vim2, press and hold the power button, while holding the button put usb into pc and wait 6-7 seconds until recognised, then release button.

may be you can short-circuit "M ".
try to connect computer。

Hi All,

I am still not able to update the image…
Finally I have my console with me but still not able to trigger upgrade process via UBS and sdcard.

Please suggest me what should I do… how can I reset the emmc so that I end up into default state. .

1 How can I upgrade the image from sdcard to emmc ?
2 How can I upgrade the mate image over android one ?

Attache is the console logs.

can you see “Hit Enter or space or Ctrl+C key to stop autoboot – : 0 ” ?

please press Enter or space or Ctrl+C key into uboot。

than connect you board and computer with “usb type C"
and input ''update",press enter into upgrade mode。

kvim2# update

Hi amoon,

In your log I found this:

mac address: 98:aa:fc:60:47:37
[KM]Error:f[key_manage_query_size]L507:key[deviceid] not programed yet
Detect function key
gpio: pin GPIOAO_2 (gpio 102) value is 1
gpio: pin GPIOAO_2 (gpio 102) value is 1

It seems that you pressed the FUNCTION KEY not POWER KEY.

Let VIM enter into upgrade mode to complete the upgrading:
Long press Power key without release
Short press Reset key and release
Count 2-3 seconds and release the Power key to enter into upgrade mode

You can refer to upgrade via a USB-C cable for more details.

And you can enter U-boot command line and execute run update to enter upgrade mode, too.


yep I got the board to flash the image.Thanks for pointing my mistake.

Here is what I did at my end.
1 Flash the upgrade image to microSD card and attached to the board.
2 connected the VIM2 board to power on via Type C cable.
3 Long press the power key without release and press the reset key.
this will land you into u-boot prompt
4 “run update” that will flash the image on the board from microSD card.

By the way vim2 android image supported 4.9.x kernel or 3.14.x kernel.
current upgrade kernel is 3.14.29.

I am going to try the flash ubuntu mate Image for testing.:grinning:

Hi amoon,

Android kernel only support 3.14.29 now.
And VIM2 ubuntu image only support 4.9.


Thanks for your conformation.

I manage to flash vim2 mate image on the flash.
It look like lot’s of work is done by the u-boot for upgrade and flash of Image.