Using of UART on VIM3

Hi all,
i’m a new user of Khadas.
I need to have an rx-tx communication with khadas to excange data with some other devices like ST arm micro-controller or sensors.

Until now I follow next steps:

  1. Flash eMMC with latest ubuntu desktop find here
  2. Follow this approach to open uart. In detail:
    2.1 I’m connecting using an usb/ttl converter to check connection, pin 15-16-17, as you can see
    2.2 I’m using PuTTY on windows to connect to instancied com3 but using on khadas command
    echo khadas | sudo tee /dev/ttyS0 or echo khadas | sudo tee /dev/ttyS1 nothing appear in PuTTY terminal. To be clear using ttyS1 in sudo tee command stuck Khadas until ctrl+c. In my dev I can find only ttyS0 and ttyS1
    2.2.1 Writing on PuTTY doesn’t have any kind of feedback.

Where’s my fault? Any suggestions?

Thanks in advance,

Hello, Please try swapping the RX and TX lines. Tool TX to GPIO RX. Tool RX to GPIO TX.

@baldodavi From your picture, your TX and RX is reversed.

Main issue was the lack of ttyS3 now solved.
Now I can communicate with serial without any issue.

Thanks a lot.

hello Mr baldodavi,
I also have same problem.
How did you activate your ttyS3?

Hi Denis,
I’ve observe a behavoir in my 4 months Khadas version: sometimes, during startup, there’s issues during establish connections between khadas and rest of the world, simply I reset khadas using hardware and issue was solved.

Thanks for your reply.

“reset” is different with “reboot”?
What is the “reset”? and how to do “reset”?