USB WiFi rtl8812au adapter on VIMx.Ubuntu.mainline.5.5.xfce.bionic.test.emmc.kresq

I installed the VIMx.Ubuntu.mainline.5.5.xfce.bionic.test.emmc.kresq. It is working well. denn i tried use my usb wifi adapter rtl8812au (EDIMAX EW-7811UAC). I installed with dkms the drivers…

dkms status
rtl8812au, added

I coundn’t activate the adapter, it ist not working und I got following errors… I think , some file are missing and need more linux kernel files …

Can you help me? What is wrong…

Thank you for your help

here logs after executing dkms autoinstall

LD [M] /var/lib/dkms/rtl8812au/ Building modules, stage 2. MODPOST 1 modules
/bin/sh: 1: scripts/mod/modpost: not found
scripts/Makefile.modpost:93: recipe for target ‘__modpost’ failed
make[2]: *** [__modpost] Error 127
Makefile:1605: recipe for target ‘modules’ failed
make[1]: *** [modules] Error 2
make[1]: Leaving directory ‘/usr/src/linux-headers-5.5.0-rc2’
Makefile:1457: recipe for target ‘modules’ failed
make: *** [modules] Error 2

you need to add the support for it by modifying the kernel config and rebuild the image

You need to use Fenix to build the image by yourself,

modify the kernel config to enable support for it, so it gets the required modules and it will work

@tuncay I think it need more drivers supports in kernel , but mainline kernel requires you to add your own driver many times .

I tried to compile my own kernel with fenix scripts… but the scripts are not working under windows sub linux 2 and I couldn’t find kernel config files.

Why we don’t have (usb wifi) module support in the mainline kernel? I think many people need this.

May be, I can use armbian to get module support… but it is not easy to install armbian on vim3 too… I should copy some dtb files , and there is no krescue image for armbian.