Usb ports do not work

I have vim 1 pro. A few days ago did not work usb ports. Do not work flash drives, mouse, keyboard, and more. Currently installed ubuntu 18.04. In the terminal with the lsusb command, devices are not detected. Is it really a breakdown?

@shurx, Can’t it be used these days? Have you updated your firmware?

Firmware installed VIM1_Ubuntu-xfce-bionic_Linux-4.9_arm64_EMMC_V20181030. All package updates installed through the terminal in putty. A week ago, the usb port worked well, I connected a backup disk. And two days ago, the ports stopped working. I restarted khadas several times and the problem was not solved. I noticed that the red indicator is slowly flickering. It used to burn constantly.
Sorry for my bad english.

@shurx Are the USB ports on the left and right broken? I suggest you rewrite a firmware. Now I’m not sure what caused it.

Yes, left and right. If it does not work after the firmware, you will have to look for an alternative.

@shurx,does it work atfer rewrite the firamware ?

Checked three firmwares with different OS. Usb does not work. The guys from the technical forum I was told that the problem is in the controller FE8.1, it is not serviceable. In repair to give no time because khadas is used as the server. I’ll buy a replacement.

Hello, I may have missed it, but do GPIO USBs also fail to work? Just curious.

Through gpio also does not work. This is logical, hub 4 Usb port works through the controller FE8.1 Voltage 5 volts everywhere. Already ordered the 5 g’s controller, will replace. Then write.

Yes, it does stand to reason.
Good luck with the replacement.