USB port not working

Which version of system do you use? Khadas official images, self built images, or others?

Khadas ubuntu image

Please describe your issue below:

I wanted to install an image I made of another VIM4 on the emmc of my vim4, as I did several times. So I inserted my USB key with the image and made the image on the emmc as usual. But once the image is installed, the USB port on which my USB key was inserted does not work anymore, there is no more power going through. Can the USB port be deactivated when I install an image? How can I reactivate it?

1 Like

Could you try to install the image with oowow online to check whether it works?

I tried to make a new image from oowow online, but the USB port still doesn’t work. I tried to do lsusb to see what my system detects, but the system shows that nothing is connected on this USB port. It’s like there is no power anymore on this port.

Try with a powered USB hub.

1 Like

It may be that the hardware was accidentally damaged. :slightly_frowning_face: Please use OOWOW again and reinstall other firmware. To prove this conjecture.

I tried to reinstall an image, then I reinstalled oowow with the image you can put on sd card. But the port still doesn’t work, I don’t understand why it would be physically damaged, I didn’t make a short-circuit.

Hello @Jonvu27
Good luck often comes with bad things.Please apply after sale, our engineers may be able to give it new life. :grinning:

$ lsusb

If it is recognized you have a software issue, if it does not show up it might be the usb drive or the board.

USB drives will get flaky with use and age, I would try another one.

Also try this,

$ dmesg | grep USB

That will give you a screen full of info, so scroll and look for your device.

I tried

$ dmesg | grep USB

But there is no difference if a usb stick is plugged or not .

[    0.527873] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    0.528201] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
[    0.533892] USB Video Class driver (1.1.1)
[    0.612459] usbhid: USB HID core driver
[    4.944796] amlogic-crg-drd-usb2 fe03a000.crgphy20: USB2 phy probe:phy_mem:0xfe03a000, iomap phy_base:0xffffffc01033a000
[    4.946522] amlogic-crg-drd-usb2 fe03a020.crgphy21: USB2 phy probe:phy_mem:0xfe03a020, iomap phy_base:0xffffffc010341020
[    4.949552] amlogic-crg-drd-usb3 fe03a080.crg3phy21: USB3 phy probe:phy_mem:0xfe03a080, iomap phy_base:0xffffffc010349080
[    4.950967] amlogic-crg-drd-usb3 fe03a080.crg3phy20: USB3 phy probe:phy_mem:0xfe03a080, iomap phy_base:0xffffffc010351080
[    5.251280] xhci-hcd new USB bus registered, assigned bus number 1
[    5.254374] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 5.04
[    5.255288] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    5.258772] hub 1-0:1.0: USB hub found
[    5.259949] xhci-hcd new USB bus registered, assigned bus number 2
[    5.260937] xhci-hcd Host supports USB 3.1 Enhanced SuperSpeed
[    5.262968] usb usb2: New USB device found, idVendor=1d6b, idProduct=0003, bcdDevice= 5.04
[    5.263976] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    5.267429] hub 2-0:1.0: USB hub found
[    5.513171] usb 1-1: new high-speed USB device number 2 using xhci-hcd
[    5.665609] usb 1-1: New USB device found, idVendor=1a40, idProduct=0101, bcdDevice= 1.11
[    5.665981] usb 1-1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[    5.666900] usb 1-1: Product: USB 2.0 Hub
[    5.668053] hub 1-1:1.0: USB hub found
[    6.113161] usb 1-1.1: new full-speed USB device number 3 using xhci-hcd
[    6.337311] usb 1-1.1: New USB device found, idVendor=046d, idProduct=c534, bcdDevice=29.01
[    6.337694] usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    6.338635] usb 1-1.1: Product: USB Receiver
[    6.343778] logitech-djreceiver 0003:046D:C534.0001: hidraw0: USB HID v1.11 Keyboard [Logitech USB Receiver] on
[    6.404843] logitech-djreceiver 0003:046D:C534.0002: hiddev96,hidraw1: USB HID v1.11 Mouse [Logitech USB Receiver] on
[    6.480226] logitech-hidpp-device 0003:046D:4023.0003: input,hidraw2: USB HID v1.11 Keyboard [Logitech Wireless Keyboard PID:4023] on
[    6.489996] logitech-hidpp-device 0003:046D:4091.0004: input,hidraw3: USB HID v1.11 Mouse [Logitech Wireless Mouse] on

Since the mouse and keyboard are working this leaves the USB thumb drive as suspected problem.

Can you use the mouse from that same port that does not work for USB drive?

I can not use the mouse on the other port.

While discussing with khadas support we came to the conclusion that the hardware is damaged and that we could not do anything about the software.