Upgrade via usb-c failed [Vim1]

[17:40:55 749][HUB3-6][Inf]–Open device handle \?\usb#vid_1b8e&pid_c003#6&35466de&0&6#{a5dcbf10-6530-11d2-901f-00c04fb951ed} 0x0000046c
[17:40:58 810][HUB3-6][Inf]-------------Download DDR.USB-----------
[17:40:58 812][HUB3-6][Inf]–2-2-0-0
[17:40:58 812][HUB3-6][Inf]–Control write pll reg1 0xd9000000:0x000000b1
[17:40:59 320][HUB3-6][Inf]–Control write pll reg1 0xd9000000:0x00005183
[17:40:59 830][HUB3-6][Inf]–Control write pll reg1 0xd9000000:0x000000b1
[17:41:00 340][HUB3-6][Inf]–Control write pll reg1 0xd9000000:0x00005183
[17:41:00 850][HUB3-6][Inf]–Write initial succeed
[17:41:00 850][HUB3-6][Inf]–Upload encrypt at 0xc8100228
[17:41:00 852][HUB3-6][Inf]–ulValue = 0xadfc318c
[17:41:00 852][HUB3-6][Inf]–Read encrypt value succeed
[17:41:00 852][HUB3-6][Inf]–Download DDR.USB,size: 49152!
[17:41:00 867][HUB3-6][Inf]–Transfer complete 49152
[17:41:00 869][HUB3-6][Inf]–Run at address 0xd9000000
[17:41:00 875][HUB3-6][Inf]–RunInRam success
[17:41:00 898][HUB3-6][Inf]–2-2-0-0-0-1-0-0
[17:41:00 898][HUB3-6][Inf]–CheckFileRunState succeed
[17:41:30 915][HUB3-6][Err]–usbReadFile failed ret = -116
[17:41:30 915][HUB3-6][Err]–ReadPara failed
[17:41:30 917][HUB3-6][Err]–[0x10105002]Romcode/Initialize DDR/Read initialize status/USB Control setup error
[17:41:30 917][HUB3-6][Inf]–Close device handle 0x0000046

The process always failed at 2% with error [0x10105002]Romcode/Initialize DDR/Read initialize status/USB Control setup error
I have tried other usb ports but nothing changes.
My vim1 is currently run ubuntu server.

hello, can I link to your firmware?

This is the firmware: Ubuntu-server-bionic_Linux-4.9_arm64_EMMC_V20191231

Did you try different firmware, or does the problem persist ?
The error you are seeing is mostly from related to when you use firmware for a different board…
but you have the matching firmware for the respective board…
so I can’t understand what is happening here…

well, you can select “erase all” in USBBurningTool before flashing, try it, and as an option, change the cable, it is better to sew through the port in the motherboard directly

I tried several images, but all have the same error.

I thought it was the front usb ports but the same error happened with usb ports at the back.
The cable is the official cable came with the vim and the cable operates normally (can boot to ubuntu, all function normally).
I didn’t try erase all option. Is it dangerous?

I don’t know, but I have not encountered any problems.

you can also try using Krescue

It isn’t dangerous, it just removes all the system files…

It is essential to be kept enabled when hopping between different firmware like Android and Ubuntu…
and should be kept disabled when you want to upgrade android without losing all your data (just updates system files)

I would suggest trying to enable the “Erase all” option and Reflash to see if you still encounter problems…

“Erase All” - you can erase service data (sn. Mac, hdmi hdcp) and without restoring them, the firmware will then not understand how to work (but it will work).

Erase all is kind of a destroyed path. My Vim is still running ubuntu normally. If erase all then failed I will stuck with a bricked vim. That’s not ok :frowning:
I will try krescue and maybe flash new image from there.

You can’t brick your VIM so easily… and even if you did, unbricking is just a matter of reflashing…
I once bricked mine, and all I did was reflash the firmware…

If you still find it scary, you can just stick with Krescue

Hello, Do you have your VIM1 in a case? Some of the USB-C to USB-A cables are a tad short(C end) and may drop data connections when a case is used. You could try a different cable or if the VIM is in a case, remove it and try to update via USB-C again.
As Electr1 stated, the VIM line of SBCs are touch to brick. Clearing the eMMC will not brick your VIM, I have erased eMMC a couple of dozen times. Never produced any worries.

Which rom do you recommend to use for my vim 1?
krescue images

I’m using mainline uboot.

What do you mean when you say “Vim1 in a case”?
My vim 1 using the stock housing, not modifying anything.

@peerobo I was preparing a 4.9 kernel Ubuntu eMMC image for you, those Krescue images are really old… (Nearly 8 months!)

@RDFTKV says that cases make a gap between the port and the connector… so it might cause the connector to fall out, and drop the connection


Thank you very much.

Yes, like most USB cables, when the cable is connected, the power pins are engaged before the Data pins, so a cable may supply power, while having an unreliable data connection.
I don’t think the VIM 1’s original case, the acrylic sectioned case(pictured), has the issue as it is open in the back. Though it is a good idea to insure the HDMI cable’s headshell does not exert force on the USB-C connector.
If available, try a different cable anyway.

1 Like

@peerobo the image is ready, You need to login to Github to access it… you can download the zip file from here:
VIM1-Ubuntu-4.9-eMMC-20200827 Firmware


How can I write the .img file to emmc in krescue? Could you please show me?