Updating Android

I have built Android 12 for the VIM3. I am now trying to update my board following these instructions:

Unfortunately, the following command:

./tools/update bl2_boot u-boot_kvim3_noab.bin


[LUSB]ERR(L1069):Fail in start cmd, ret=-1
[LUSB]ERR(L1172):fail in parse cmd, ret=-1070

I have tried putting the board in boot mode using the P and R buttons. I also tried putting it in test mode by pressing the F button three times at startup. It doesn’t work either way. I also tried using boot-g12.py, but all it ever does it spit out the help no matter how I try to format the command.

I was able to update the board using the Windows application, but I would like to be able to do it on Linux, so I don’t have to keep switching computers.

Can anyone tell me how to update Android on the VIM3 using Linux?

I managed to get a little further, but it still isn’t working. I updated the udev rules as specified here:

Now, whenever I try: ./tools/update bl2_boot u-boot_kvim3_noab.bin it returns:

[update]No [WorldCup Device] device after scan
[update]ERR(L1095):can not find device

Also, I tried installing pyamlboot following these instructions:

It seems to have installed correctly, but when I try the following command:

boot-g12.py u-boot_kvim3_noab.bin

It returns:

boot-g12.py: command not found

Which is completely unsurprising, since that script does not exist on my computer. I tried downloading the file separately and running it, but that didn’t work either.

Any help?

I finally got it figured out. I followed these instructions:

I was using the reset and power buttons to put it in update mode. I should have pressed the F button 3 times at start up instead. One thing that isn’t mentioned in the instructions: You have to be sure and include sudo before all fastboot commands. Maybe that is obvious to someone with more experience doing this sort of thing, but it wasn’t obvious to me.

Hopefully this helps someone.