Update failed via USB burning tool

Hi there, i just got my khadas vim and so excited and decided to update to the latest root android version. However at the 99%, error prompt during verify partition. The device can’t boot at all right now. Fyi, i have tried version 161213, 161211 and all stuck at 99%. When i connect to TV, it just show dark screen.
I have created the LibreELEC image on SD card, but the VIM won’t boot from that card as well.

See attached image for the error. Hopefully yours can help me to resolved the issue. ( 2G/16G version)

Hi, Victor:
I’m uploading a ROM now, kindly have try later.

The possible cause:

  • There are two type of DDR for Khadas VIM in the two times of mass production:
    • Samsung
    • Skhynix
  • The DDR timings might need to fix for Skhynix now.

Ps: still uploading now.

Yeah…mine one confirmed is Skhynix.

Will share the link in a hour…(slow network here in China) :wink:

No problem sir, will wait :relaxed:

Hi, Victor:
Kindly have a try with this ROM and feedback to us:

Hi Gouwa,

That firmware seems to be flash fine without error and managed to bring the board back to life. Thanks a lot for the quick fixed.
Meaning that I won’t be able to install any of the firmware listed in the firmware page? Will there be a separate firmware section for this board?


Hi, Victor:
Thanks for the info.

We will update the ROMs to compatible two types DDR in these days.

Btw, are you a developer?

Update rom information, luckily mine is Samsung ddr, so it was flashable.

It’s just my luck to get the Skhynix one. When we will be getting the LibreELEC version which can be install on EMMC? By the way, I’m not a developer, I just want to get a HDMI 2.0a board which can run LibreELEC to replacing my old Pi2 board :slight_smile:

Not only you, in fact, we have arranged two SMT/Mass production now:

  • First time: with Samsang DDR
  • 2nd time: with Skhynix DDR

New LibreELEC ROM will be released in this week.

Just noticed that my board label v1.2 with production date 1610. Whereas the official website display v1.1 production date 201608 which comes with Samsung DDR. Those newer version will be based on Skhynix DDR? Am I right?

  • V11 just for engineer prototype, haven’t sale to to end-users.
  • Both the two times of SMT/Mass production are with the same PCB revision V12.
1 Like

Hi there. Tried to upgrade my Khadas VIM with VimPro_DualOS_Marshmallow_Ubuntu-16.04_170124 and had the same error as described by Victor. Did anyone have the same Problem? Any idea on how to fix it? Thx.

@G7814 do you have Khadas VIM Pro or non-pro version with 8GB of eMMC? Because only Pro supports DualOS.

1 Like

Thanks for the fast response, I use the non-pro version, which explains the issue

I got this error when i import libreelec img in vim3 can u please help me out of this

@prabhu , Hello , If you want to use EL in VIM3. You need a SD card. It can’t be burn with Burning Tools. You can reference this page.

Then how to install in emmc…?.I can’t understand

@prabhu . You can install it by this steps:

  1. Firmware burning to SDcrad
  2. Start from SDcard
  3. Installation from the command line
LibreELEC:/ # cd flash
LibreELEC:/flash # ./install2emmc.sh