Unbootable VIM1, dark screen - serial connection possible


#1

Hey folks,

have my VIM1 laying arround for long time. Never really used.
Wanted to install a DualOS on eMMC and LibreElec on SD. BUUT can’t get anything to boot from on my VIM1. Instead the display stays dark all the time (no signal).
I read the threads here and the Docs, but I do not understand how to reach my goal. Some information is even missing I think. Where to get the fitting u-boot images/binaries from?

Is the VIM a little special with the SD cards? tried two different, no luck.

How could I get some OS on the eMMC? With serial connection?
What would be the first steps on my way to DualOS + LibreElec?

I would really appreciate your help.

greetz
sponge


#2

Hello, Check Khadas Docs for info on burning firmware via USB or SD card. If after reading you need additional help or info, reply back.
Also, ref dark screen, check to insure the VIM is powered by a 2 amp or better power supply. Under performing, or under rated power supply, can lead to a dark screen on boot.


#3

Thanks for the reply.
As I said, I read the Docs already.

Got a little further with my debugging:

the first problem was, that I used “u-boot-v2018.05_VIM1_Ubuntu_20180712.bin.sd.bin” which seems not to be the right u-boot version. THIS should be made more clear in Docs etc. as there is only those two “ubuntu” Versions of u-boot for download.
Now I used “u-boot-v2015.01_VIM1_Ubuntu_20180712.bin.sd.bin” which seems to be not the right version again, but let me go this far, that I could flash “Marshmallow” to my eMMC (Android and progress bar shown on Display).
When I then remove the burnerSD and try to boot, I end in the u-boot shell and the Android OS does not start (black screen).

Where do I get the REAL/RIGHT u-boot binary from (for marshmallow only AND/OR DualOS) ?


#4

Which VIM1 do you have, 8GB or 16GB? I’m not sure, but I recall the 8GB model may not have enough space for the dual OS.

If you have a PC, flashing an Android image to your VIM might be a good place to start. From there you could get LibreELEC or Linux on SD card.

I have not used a card for flashing before.


#5

Hi Spongeman:
Yes, as RDFTKV replied above, dualOS ROM only available for 16GB+ models.

Can you specify more details when you upgrade a ROM and post here so we can figure out a solution for you.

Btw, the prebuilt u-boot images are for developers, you can directly upgrade with Android or Ubuntu ROM to wake up your VIM board.

Please let us know if any questions.

Good day!


#6

Hy folks,

I manged it to get my VIM running. Updated to Android Marshmallow on eMMC and LibreElec on SDcard, running smooth.
The KEY was to use the right u-boot (for the BurningCard)!

As I have an 16GB VIM1, I want to try getting DualOS running in eMMC.
I will update this thread, when I tried it.

Thank you very much for your response. Like in my last post, I highly recommend to clarify the part about the u-boot binary that has to be used for creating a proper BurningCard.

greetz


#7

Used this u-boot binary for BurningDisk (sha1):

fefbc336c83552d348b388a0877c5e397357c80a u-boot.bin.sd.bin

Workt out flawlesly with Marshmallow image (and DualOS image).

I heard there is a problem with the remote in LibreElec if using an image newer than Marshmallow, which is a shame.

Is there a way to solve this problem? To patch the old codes in a newer image? Something?
It’s realy anoying to have such an old Android running on any device in your network.

Did not make it to get DualOS + LibreElec (SD) running. Anybody has a tip for me?

And a really huge Problem was that there is NO space left on the ubuntu of the DualOS (only 300MB). You cant install anything, even was impossible to update the repository list (apt).
How to resize the partition of that OS?