Unable unpack images to eMMC using burn-tools

Hello. I have had my VIM3 for a a while, but to me OS support had always been sloppy compared to my other SBCs so I had not used it really.

As far as I can remember, I once had Ubuntu server installed, and it worked fine (ran all days for a long time). Then I flashed Ubuntu 18.04 Xfce on to its eMMC a long time ago, and it worked just fine, until recently when Ubuntu started complaining about swap and zram and would occasionally crash in less than 1 hour after boot.

This is why I decided to wipe eMMC OS to Android or whatever, but however, the burn-tools didn’t work on my board. I tried using both 16.04 and 18.04 hosts (both are different computers - Lenovo ThinkPad and a Lenovo ThinkCentre - which are working fine on Arch Linux, FreeBSD, Ubuntu so I think the PCs are all right) but they both failed at something like “Unpacking …[KO]”. I’m sure both of my PC Ubuntu versions are not broken, because they are installed only for your flash tools lol. Also, the git repo “utils” was up-to-date and reinstalled. The image files (I downloaded many of them just to try) were checksummed, redownloaded many times but none worked.

I tried to manually wipe the eMMC by following the guide on this site (pressing power+reset blah blah blah) but that didn’t work either, and Ubuntu Xfce just persists there, never deleted.

I think my board is bad, is it? If so, can I get replacement? If not, what is your suggestion?

Note: the board has no SD card inserted.

Please try the latest buying tool there is 2.2.0 version. This is for windoz ofcourse.

But I am not sure if the ubuntu flash tool is updated to be used with the latest images.

Afaik there is no way to erase emmc by any key modes.

Try windoz once and see if that helps, I no its annoying coz even I don’t have windoz but for this burning tool I had to install it on my spare laptop just so I can flash os on amlogic boards :frowning:

So you are suggesting that I use Windows to flash the board? Thank you, I will consider it.

I have a Windows disk lying around but they are painfully slow to use despite being almost empty, plus, ideally I would want to do it on Linux so that I don’t have to swap the disk on my laptop every time I flash my board.

Also, this is the official instruction for clearing eMMC using keys

Hello! use Krescue, there are two modes to clear emmc

I’m quite confused after reading this guide, do I need Android for what you Khadas guys call “multiboot”? Also, this SD card boot guide seems very confusing - where do I find such .dtb files for VIM3 as mentioned in the documentation?

I found a directory called dtb in /boot, is that the one I am supposed to use?

By the way, I managed to install new Ubuntu server image (latest one from dl.khadas.com) to the eMMC using Windows USB tool, the new installation again complains about zram problem although this time it never crashed - just like my first Ubuntu server installation.

Edited: Now I am able to run it without Ubuntu complaining about zram by using zramctl to reset zram1-zram4 and reboot (I also reset and recreated zram0 but I dont think that it is important here). There’s a Fenix systemd unit taken from Armbian that initializes zram after each boot I guess. After the reboot, the new zrams never fail again - I suspect the cause of failure to be the inclusion of improper zram files (or volumes) in the install image, which is copied to disk during the burning. I’ll be sure to reset the zrams after later fresh installations.

are u really need zram on server ? for common usage zram is uselessness - just blacklist it and forget about this :wink:

Oh I run boinc so the load on my little server is pretty heavy - far heavier than desktop apps :wink:
Plus, I tried importing Armbian’s zram systemd unit file but that didn’t work. And when I completely disable swap the board freezes after some time. So I had to adjust the boinc load down a bit, and had to enable Fenix zram scripts to avoid the board crashing.

Edited: Now I have completely disable ZRAM (by disabling fenix-zram-config.service) and instead use a 1G swapfile and now the board runs great.