Unable to start oowow from SD-card on Vim3


I’ve got 3 Khadas VIM3 devices on my table right now. The emmc on all of them have been erased using the USB Burn Tool and disconnecting the device after reaching 15%.

I have a SD-card which I’ve burned the latest version of oowow for vim3 onto using Etcher:

However, I cannot seem to boot from the SD card at all? I tried installing Android on one device, put the SD card inside and boot up the device, but it went straight to android.

I have also tried the hardware keys like hold function key and plug in the USB-C cable, hold function key and short press reset key but nothing seems to be working. I don’t think I had these issues with Krescue when I was playing around with these devices Sept-Oct 2022.

The LED indicators on the 2 devices that have the eMMc wiped show nothing when powered on. No signal on HDMI, though if I press function 3 times after resetting or plugging in the USB it blinks a few times to indicate its in upgrade mode. On the device with Android installed the white led indicator shows up as soon as you power on or boot up the device.

What am I doing wrong here? I’ve read through all the documentation and tried different things

Hello @Dizzzy

@hyphop will help you then.

Android can block possibilities to bootup from sd or usb

Please provide more details which android system was installed on eMMC, after we can provide some solutions

PS: if eMMC was cleaned, bootup from sd must works


if u don’t need eMMC content please check

burn next image http://dl.khadas.com/firmware/uboot/mainline/VIM3.uboot-mainline.emmc.aml.img by amlogic burn software

this minimal uboot installation must initiate HDMI and keyboard in any way + allowed next step as bootup oowow from SD or USB

welcome for any help :wink:

Thank you so much @hyphop! The image you provided of Uboot actually works. I’ve only tested this on one device so far, I have 2 more on my table that I want to test this on.

The device running Android was running this image: https://dl.khadas.com/firmware/vim3/android/vim3-android-9-64bit-v230719.img.xz
The device running Ubuntu was running this image: https://dl.khadas.com/firmware/vim3/ubuntu/emmc/vim3-ubuntu-20.04-server-linux-4.9-fenix-1.5-230425-emmc.img.xz

The one device I have tested this on now, in the Amlogic burn software, I checked Erase flash (Erase all) and Erase bootloader, flashed and it booted up to oowow instantly.

I tried inserting the SD-card on one of the devices that has Ubuntu installed and it just booted directly to the shell prompt even if function was held + reset pressed. :slight_smile: