Unable to compile android 6.0 for vim1

Hello everybody,

I have been stuck for 2 weeks compiling android 6.0 on ubuntu 14.04.
Every time I solve a problem, another problem appears, and so on endlessly.

I followed exactly all the steps indicated on the khadas site for the android build, created the environment recommended by android, installed the amlogic tools etc…

but it still doesn’t work.

thanks a lot for your help :slightly_smiling_face:

I have never used android. Here is a link to the khadas download site. They have several ready to run images.

If you use Krescue on a SD it works very well to install into emmc.

Thank you for your answer but I’m talking about the AOSP build, that is to say rebuild the Android image in order to customize it for our product…

Just looked at the android site and seen that their build setup is similar to Khadas fenix. Using the source build/envsetup.sh that works very well with fenix.

Might have to upgrade your ubuntu OS to 20.04 so everything is current. Pretty sure just looking is about as far as I will go on the android. Hope you get it all worked out.

ok thanks @foxsquirrel, so i tried with ubuntu 18.04 and 20.04 and i still have the same error:
I managed to compile the u-boot with
make CROSS_COMPILE=aarch64-linux-gnu- kvim_defconfig and
make CROSS_COMPILE=aarch64-linux-gnu-
and its done,

but when i try to compile android with: make -j4 otapackage (after running these commands which worked: source build/envsetup.sh and lunch kvim-userdebug-32)

I get this error:

make: *** No rule to make target "prebuilts/qemu-kernel/arm/LINUX_KERNEL_COPYING", needed for "out/target/product/kvim/obj/NOTICE_FILES/src/kernel.txt". Stop. make: *** Waiting for unfinished tasks....

the folder prebuilts/qemu-kernel is empty…