Ubuntu Server ROM V170515 released [EMMC INATALLATION]

It’s been awhile since the last Ubuntu release, here we release an new Ubuntu Server ROM V170515 first, and regarding the new Ubuntu-Mate ROM will be follow in a next few days.

Check Firmware Page to download the ROM.

ROM Infos:

  • ROM version: Vim_Ubuntu-server-16.04_V170515.7z
  • MD5SUM: 5dace63f5b6db06377ea241b4ef7e153
  • The ROM is for eMMC installation
  • Account info:
    • User: root
    • Password: khadas
  • LED state:
    • Booting: heartbeat
    • Boot up: breathe

Change logs:

  • better 32-bit display(Before was 24-bit)
  • Add standard Linux GPIO Lib support, and setup PIN29/30/31/32/33/37 as generic IO
  • Enable UART bus (PIN15/16) as default
  • Enable I2S bus(PIN25/26) as default
  • Add bluetooth support
  • Add more HDMI output resolutions(haven’t full completed yet)
  • Upgrade to the latest ubuntu-16.04.2 packages

Upgrade guidance:


1) Create Admin user with ‘sudo’ permission

# adduser khadas
# usermod -aG sudo,adm khadas

It’s not recommended to login as root user directly, you can login as the Admin user you create above:

root@Khadas:~# su khadas
To run a command as administrator (user "root"), use "sudo <command>".
See "man sudo_root" for details.


2) HDMI Overscan

# echo 10 10 1909 1069 > /sys/class/graphics/fb0/window_axis
# echo 0x10001 > /sys/class/graphics/fb0/free_scale

Tips: window_axis parameter valued as: left + bottom + right + top

  • left + right = 1919
  • bottom + top = 1079

3) Setup network

Note to plug in the LAN cable and run:

# echo "auto eth0" >> /etc/network/interfaces
# echo "iface eth0 inet dhcp" >> /etc/network/interfaces
# /etc/init.d/networking restart
Restarting networking (via systemctl): networking.service.
$ ifconfig 
eth0      Link encap:Ethernet  HWaddr 00:15:18:01:81:31  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::215:18ff:fe01:8131/64 Scope:Link
          RX packets:9 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1778 (1.7 KB)  TX bytes:1996 (1.9 KB)


4) Setup bluetooth via CLI
As we haven’t achive the bluetooth firmware mach automate, and currently our build is for VIM Pro. So if you are a VIM Basic(2GB + 8GB + AP6212) user, you should edit /usr/local/bin/bluetooth-khadas.sh manually first by comment the VIM Pro line and uncomment the VIM line:


# VIM Pro
#/usr/local/bin/brcm_patchram_plus --patchram /lib/firmware/brcm/BCM4345C0.hcd --enable_hci --no2bytes --tosleep 1000 /dev/ttyS1

/usr/local/bin/brcm_patchram_plus --patchram /lib/firmware/brcm/bcm43438a1.hcd --enable_hci --no2bytes --tosleep 1000 /dev/ttyS1

/bin/sleep 1
/usr/bin/hciattach /dev/ttyS1 any

It’s common way with other Ubuntu OS to pair & connect bluetooth devices on Khadas VIM, and follows two for reference:

If everything works fine, the bluetooth service should be running. You can run systemctl to check it:

# systemctl status bluetooth-khadas
● bluetooth-khadas.service - Khadas Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth-khadas.service; enabled; vendor
 preset: enabled)
   Active: active (running) since Thu 2016-02-11 16:28:15 UTC; 40s ag
  Process: 2109 ExecStart=/usr/local/bin/bluetooth-khadas.sh (code=exited, statu
 Main PID: 2179 (hciattach)
   CGroup: /system.slice/bluetooth-khadas.service
           └─2179 /usr/bin/hciattach /dev/ttyS1 any

Feb 11 16:28:06 Khadas systemd[1]: Starting Khadas Bluetooth service...
Feb 11 16:28:14 Khadas bluetooth-khadas.sh[2109]: Done setting line discpline
Feb 11 16:28:15 Khadas bluetooth-khadas.sh[2109]: Device setup complete
Feb 11 16:28:15 Khadas systemd[1]: Started Khadas Bluetooth service.

5) Using GPIO
GPIO list:

  • PIN29 / GPIOH7: 178
  • PIN30 / GPIOH6: 177
  • PIN31 / GPIOH9: 180
  • PIN32 / GPIOH8: 179
  • PIN33 / GPIOAO6: 151
  • PIN37 / GPIOH5: 176

To use a GPIO, shoud export first, example:

# echo  176 > /sys/class/gpio/export

Output mode:

# echo  out  > /sys/class/gpio/gpio176/direction
# echo  0 > /sys/class/gpio/gpio176/value
# echo  1 > /sys/class/gpio/gpio176/value

Input mode:

# echo  in  > /sys/class/gpio/gpio176/direction
# cat /sys/class/gpio/gpio176/value 

6) Install Mate desktop[Optional]

Edit source.list to add [universe] and [multiverse] repositories:

# sed -i "s/^# deb/deb/g" /etc/apt/sources.list


# apt update
# apt upgrade

Install the mate packages:

# apt install mate-desktop-environment ubuntu-mate-core

Install bluetooth GUI packages:

# apt install bluetooth blueman bluez bluez-tools

7) Setup different HDMI output resolutions

Have fun!


I did expect Ubuntu Mate, these few days were 15 days, i wonder how much longer we will wait for it, will it even be available this month???

And will you even release sd card installation, or we will once again need to wait, when most of the boards, if not all, have a sd card installable operating system, then i don’t see a problem of making it available for Vim?

Is this using mainline Linux kernel?

1 Like

How to enter a static IP address?

Actually, it’s quite common way to setup network on VIM with standard Ubuntu OS, follows for your reference:

You can google for the more answers.

Hi, Tommy21:
Feel so sorry for that.

For Ubuntu-Mate you can follow the instructions to install the Desktop based the Ubuntu server ROM.

As our team are still stuck at the more HDMI output resolutions, so we will release new Mate ROM after we got it fixed.

Regarding the uSD card installation ROM, I remembered I promised you to do that, so we will also do that, just give us some time :wink:


Ok, thanks for replying, so the difference between server and Mate will only be in resolutions, i recently bought new monitor so resolution shouldnt be an issue anymore.

I was getting a little impatient because 6 months have passed, now i know why, did you check how odroid c2 uses more resolutions?

Release sd card installation for server and Mate, not only for Mate, i am sure people would want this, almost every sbc has sd card installation.

Hooray to Gouwa and all the Khadas team for this achievement, thank you very much,
This new ubuntu server is what I did wait for during these last weeks.

I’ll update my board ASAP and will give the community some feedback.


What did you solve from this list, what will be included in the Mate update?

@Terry, @Gouwa, can you answer?

1 Like

Great news, well done guys!

I choosed to configure eth0 as not use dhcp as boot time is longer if I have no rj45 cable connected,
so I did this:

echo “auto eth0” >> /etc/network/interfaces
echo “iface eth0 inet manual” >> /etc/network/interfaces
sudo ifup eth0
then I rebooted
connected the Lan cable to my router
sudo dhclient eth0

but this command hangs forever

So, I changed manual to dhcp in /etc/network/services then rebooted , then…

khadas@Khadas:~$ sudo /etc/init.d/networking restart
Restarting networking (via systemctl): networking.service
Job for networking.service failed because a timeout was exceeded. See “systemctl status networking.service” and “journalctl -xe” for details.

Visibly, I am not able to connect to my wired network

Please tell ma what I did wrong

@Gouwa, @Terry, any news about the update, will it even be released this month?

What features are expected to work, is there any progress regarding 2d/3d Mali acceleration?

has anyone here managed to have a working ethernet connection w/ this version please ?

So ethernet doesn’t work, what about wifi, i assume wifi also doesn’t work?

Why they didn’t fix this, this is a big issue.

without wired internet access, impossible to configure the Wi-Fi

Tbh i have installed Ubuntu server, but i have added a Mate DE, i wanted to check are there any improvements after 3 months of waiting.

I know ethernet doesnt work, it starts to work after writing those terminal commands for network restart, and you have to type it every time you turn on the device.

I thought i maybe did something wrong, didn’t want to reflash the device, but now i see i am not the only one, so we can consider this as a backward step.

After all those promises about new features Vim will have, video playback is still the same, i didn’t see any improvement, at least wifi and ethernet worked flawlessy in the version from february.

I tried it because i was hoping for 2d/3d acceleration, i still hope for that, but i don’t want to wait forever.

I would like to see some answers from Khadas staff, but no one is answering, they were so active in the beginning, and now they reply very rarely.

If i knew then that we will have to wait so long, i wouldn’t have bought this device.

Ethernet working for me without any issues on Vim Pro after following the steps in the first post. Those settings seem to be stored since it works without any issues after rebooting.

sorry to say, this release is a regression in terms of user experience.
Ethernet now works but is slow, WiFi not able to work after a few hours of fight

I would like to see some answers from Khadas staff, there is little or no response from them, i would like to know some information, and i am sure many of you would like to know it too.

They were much more helpful in the beginning, don’t know why, maybe they are working on Vim2, or maybe they are busy with updating Vim, but it would be fair from them to dedicate few minutes a day to us, Vim users.

ethernet works OK now that I used a different router , but wifi , after additional 3hours trying everything I can find (I managed to make it work in previous ubuntu server version, and in rpi3 using wpa_supplicant), is still an epic failure