Ubuntu on EMMC in VIM3 Pro


I am trying to install Ubuntu on eMMC in my VIM3 Pro but every time I burn the image with USB Burning Tool using recovery mode failed. Everything works fine but I am not able to boot it after successfully burning the image on VIM3. I was able to get Ubuntu running on USB Flash drive but no luck on eMMC. Please suggest

Hello, Please link to the eMMC file you used.
You may also want to look in to Krescue.

Here is the link to eMMC file https://dl.khadas.com/Firmware/VIM3/Ubuntu/EMMC/VIM3_Ubuntu-gnome-focal_Linux-4.9_arm64_EMMC_V0.9-20200530.7z

I will attempt to install it on my VIM3. Will be a couple of hours before I am with the VIM3. I will post back with what I find.

Thanks. Android image works fine on eMMC but Ubuntu… I’ll wait for your outcome

I flashed my VIM3 Pro with the image you linked to. I flashed over Android on the eMMC. I used the USB Burning Tool, version 2.2.0.
I did not experience any issues with the flashing.
First power on after flashing brought up the Login screen, logged in using password khadas. All seems well.

When I use the USB Burning Tool, I always set the “Erase all” option prior to flashing.
Maybe the download was not 100%, re-download the file and try to flash again.

What version of Windows are you flashing from?

Let me know how it goes.

On my end VIM3 Pro board’s power LED start blinking after a minute or two upon booting after burning Ubuntu. And yes, I never selected erase all. I just keep selected the default option which says Normal erase. Maybe this is the reason. I’ll re-download the image and let you know

Same thing happened. VIM3 Pro’s led start blinking after a minute with no display on LCD attached with HDMI

I forgot to mention that I have also tried the KRescue and such blinking light was the indication of booting in krescue

There are no miracles, please do everything according to the instructions docs.khadas, try different images … good luck!:slightly_smiling_face:

I understand but what does the blinking light means? I am unable to find it out in documentation

Did your firmware go 100% in the USB Burning Tool?

Here is the result which I just flashed. Now going to test it

This is the perfect shot! :wink::+1:

Yep, now it has successfully loaded the firmware, its as easy as that
follow every thing right and even god is on your side to help you :smile:

yes but still no display with blinking led light only

try a different monitor, there are definitely no problems with vim!

that’s what I am going to do but the same monitor works fine when I burn android image

just to update. Just flashed the Android Pie image and the VIM3 booted successfully. Don’t know what is wrong with Ubuntu (tried focal and bionic with no joy). I am again stuck with android :frowning:

some kind of peripheral problem