Ubuntu issue creating too much conrast on display

I’ve just had my VIM3 arrive and I’m very excited to get going, Except, after installing Ubuntu, I have extremely high contrast as default. I’ve attached an image below.

The whole screen is showing as if it’s green and pink and in a high contrast setting by default. No issue with screen (TV as monitor) or cables as I have tested other peices in the signal chain so must be VIM3, specifically Ubuntu (android worked fine).

Has anyone else had this? What’s the workaround?

Thanks in advance for any help.

@matthewrockell which firmware you used ? This may be due to a mismatch between uboot and the kernel. Is this your own compiled firmware?

Hi @Frank, it’s not my own firmware. I think it might be because ubuntu was running from within the sdcard, not sure though.

My next approach is to use my ubuntu laptop to upgrade the firmware vis usb C cable. I’m following the instructions here: https://docs.khadas.com/vim3/UpgradeViaUSBCable.html but when I get up to the point to boot VIM3 in upgrade mode and check it’s connected via usb, my ubuntu laptop doesn’t recognise it being connected. Do you know what I should do next?

EDIT: When installing the burning tool, I’m getting the all of the outputs the page expects, but also realise the Toneboard tool is intalled as well. Could this be an issue?

@matthewrockell The simplest way is into TST mode . Connect you board to PC with type-C port.Quickly press the function key three times in two seconds . you will see the blue led twinkle . When the flicker stops, you can burn the firmware directly.

How do I burn the firmware directly if I can’t see the eMMC storage of the VIM as a location on my laptop I can burn to? It’s not showing as another disk.


Use the tool in this page.It will Install the corresponding driver to automatically identify your board.

That’s the page I’ve been using the instructions from. When I get to the point where I do this:

$lsusb | grep Amlogic

I don’t get any result.

Could this problem be caused by the laptop I’m doing this from being ubuntu 18.04 and not 16.04 as the page suggests?

Perhaps I could try to create a burning card from command line:

When I read through the instructions, it turns out there’s no u-boot files in the VIM3 area of the site. Is the option of a burning card not available yet?

Sorry, I’m sure I’m doing something wrong or not understanding instructions very well, but I’m really quite confused. I just want to try and get Ubuntu installed on the eMMC of my VIM3 and start playing.


I think you should check you connect . Did you use the type-C port to connect you PC ? And get into the upgrade mode in the right way. Can you take a picture of how you connect?

You don’t need this document to burn firmware through type-C.

I have checked my connections. I have my VIM3 connected to the computer by the usb-c port. I have pressed the function button three times quickly to try and enter upgrade mode. When I do this, the blue twinkles a few times and then the VIM restarts back into the pre-loaded android os. I run the command lsusb | grep Amlogic and get no output.

Can you show me what I’m meant to be seeing here?

I know it’s not the same method. I’m just looking for any way possible to get ubuntu up and running :slight_smile:

@matthewrockell If the blue led was twinkles .it mean the board try to enter upgrade mode . If it pre-loaded android os. It mean that you don’t connect to the PC . If you sure you connect it right .maybe you need to Replace the data line and try again.

You can burn the firmware into SD card and boot with it .

Hello, If I push the middle button(function) quickly three times immediately after powering the board, I am able to reliably get the VIM3 to enter update mode.
Maybe it is a timing issue with your presses.
I don’t count to three pushes, I just keep doing(within reason) it until it shows up in the tool.

I’ll try a new usb cable as well.

Otherwise, when I boot using the SD card, that’s when I get the crazy display issue. Is there a way I can boot from the sd card, then from that version of ubuntu, upgrade the onboard emmc with the operating system so I’m not always booting from SD?

@matthewrockell TST Mode is the simplest way . Can you take a picture of how you connect? I haven’t seen anything like this. I don’t have a clue now.

See here for difference between Booting card and Burning card.


I have my MacBook running ubuntu 16.04 (I reinstalled earlier version) plugged into the usb-c of the VIM3.

@matthewrockell Can you try with the original data line . Because the data line must have the function of data transmission.I’m not sure if you have this line.At the same time, you need to unplug your HDMI line.


Changing the usb cable worked! I was using a samsung cable that came with my phone/tablet, and switched to a generic one that came with a portable charging battery and it’s now recognising the usb!

1 Like