Ubuntu images problem

Unable to flash these two official images:
Edge_Ubuntu-lxde-bionic_Linux-4.4_arm64_EMMC_V20190116
Edge_Ubuntu-lxde-bionic_Linux-4.4_arm64_EMMC_V20181115

I used SDDiskTool to create the burning card with several micro sd cards but kept receiving “write mbr failed” messages. I also tried to flash the images with the Android Tool. The edge-v was put to loader mode. When click to upgrade I got the message “download firmware failed”.

are the two images corrupted?

If the eMMC already has Android image in it, you have to enter MASKROM mode to download Ubuntu.

Hi Nick
if run an external system and completely erase eMMC, then can flash without the MaskRoom mode ?

thanks for the advice. will try later.

in the meantime, do you have any idea why burning with SDDiskTool causes the “write mbr failed” problem? I even tried a brand new micro sd without success.

Hello Oleg,

Yes, you can. But we still suggestyou to use TST mode to enter MASKROM mode, it’s very convenient.

Hello @Wyfwyf,

We will check it next week.

@frank , please followup.

If EDGE is installed on the Capitan and in the case, it is difficult to get to the buttons (Functions\restart\power on) or M-register. By the way, the size of the M-register is very small, it would be better to have a micro-button. :slight_smile:

Hi @Wyfwyf, I’ve seen similar problems, but I’m not sure if you’re in the same situation as I am.I used a 16g SD card. After burning one image, I wanted to burn another image. There was a problem you met. My solution is to format using the formatting tool that comes with Windows.It’s diskpart.You can try it.If it doesn’t work out, I hope you can provide a screenshot and I’ll try to reproduce it.

Thank you Frank. I tried diskpart to format but the problem is still there. Pls see the screenshots.


Anyway I used the USB method to install Linux successfully by putting the board into maskrom mode, as suggested by Nick.![1|589x500]

Hi @Wyfwyf , I am so sorry. This tool just support with Android.Because Ubunt firmware is used GPT partition,isn’t MBR partition.