Ubuntu 22.04 Application Store

Which version of system do you use? Khadas official images, self built images, or others?

Ubuntu 22.04 from Khadas image of Dec 29, 2022

Please describe your issue below:


I’ve been using Edge2 for a few weeks using the Ubuntu 22.04 from your image of December 2022. I’ve noticed that Ubuntu installed from your image is a very stripped-down version compared to a standard Ubuntu 22.04 installation. Many applications that are normally installed in official distributions are missing. Some of the applications I need I manage to install myself and sometimes it turns out that they work well, and sometimes, unfortunately, they do not work. Several applications that I installed on other computers with official Ubuntu 22.04 via the Application Store cannot be installed by myself. Can I install and run on Ubuntu 22.04 from your image the Application Store?


If you know the name of the package you want to install open a terminal

$sudo apt install <name of package>

If it is already packaged it will run on your board. Building from source can be a challange at times.

What program do you need and cannot get working?

1 Like

Thank you foxsquirrel for your advice. Today I tried to install VLC media player from the terminal. I used the command

$ sudo apt install vlc

There were no error messages, but the VLC icon did not appear in Applications. When I tried to launch VLC from the Terminal with the

$ vlc

command, there was no error message, but the VLC’s GUI did not appear. I plan to try with the Python AI Toolkit and Dropbox. How can I find out the full package names?

Is it possible to install the Ubuntu Application Store? That would be the most convenient option.

Just looked at the website.

Highly suspect the issue is with Wayland since they are only supporting ubuntu 18.04. That release was still X11.

To find available packages for your system

$ apt-cache search <name or partial name of package>

for example:

$ apt-cache search vlc

Just installed it on a Vim3 Pro that is is running X11 and it does install

To start it

$ vlc

That will start it then the bad part…

If you are okay with letting others have access to your machine then continue on. If not then don’t click continue and go back to the cli and

$ sudo apt autoremove vlc

Thanks for your helpful advice. As for the suggestion that Wayland might be the problem, probably not. I’m using the VLC on the Raspberry Pi 4 under Ubuntu 22.10 and on the Intel’s NUC (i5 8th generation) under Ubuntu 22.04. In both cases I use Wayland and the VLC works great for me with my DAC connected via USB. Installing the VLC on the Rasberry Pi 4, via the Application Store, was painless. I was hoping that having music organised on Rasberry Pi, it would be even better on Edge2. Both SBCs are based on arm64, so I was hoping it would be similar or even better, because Edge 2 has a better processor and more RAM. Knowing that the problem wasn’t with Wayland, I dug further. I noticed the mention of a snap in the screenshot you attached. After trying to install the snap, I got a message that there was no VLC snap for the arm64. But I knew I had VLC installed via Application Store on arm based SBC. I searched further on the Internet and found a mention of vlc-pi. Of course, the Khadas Edge2 is not a Raspberry Pi, but I thought maybe it would work (I have both SBCs working under Ubuntu and both have a similar processor). After a few tries, it worked. Sometimes I had an error message, but fortunately in those cases there was a suggestion on how to extend the command I was originally using, or what other command executed in the Terminal might help. I will not describe my attempts in detail, because reading it would be a waste of time, but here is the sequence of commands that allowed me to finally install VLC on Edge2 under Ubuntu 22.04 desktop version:

$ sudo snap install vlc-pi --edge --devmode
$ sudo snap connect vlc-pi:hardware-observe

The icon in the application grid has appeared and the program seems to be working properly. Well, it turned out that I can use VLC to listen to music — in the sound settings dialog box I see moving bars at the HDMI output, but there is a small problem :slight_smile: — I can’t hear anything. I should have started by checking if there was a chance to play the sound on Edge2. I’ve only just noticed threads in this forum that indicate audio issues with Edge2. If I knew that, I wouldn’t even start with VLC. In addition, the system does not see my USB-connected DACs (there were no problems with my DAC on the RB Pi 4).

Now I see how naive I was hoping that you can install whatever you want through the Application Store :-). It doesn’t change the fact that I like Edge2 very much and think it’s a great SBC, but only for selected uses and applications.

Hello @witold

Can you try the steps below to check the audio issue?

sudo mv /etc/pulse/default.pa /etc/pulse/default.pa.backup
wget https://dl.khadas.com/.test/default.pa
sudo mv default.pa /etc/pulse/default.pa
sudo reboot

After reboot, please select the DAC devide in System Setting->Sound->Oupput Device if you want to playback with your UAB DAC.

something which worked well for me was to install mpv instead of vlc. and in the sound settings, make sure i was using hdmi sound from the hdmi port (standard hdmi cable, not usb to hdmi).

the command for this is: sudo apt install mpv

Thank you numbqq. Your modified PulseAudio startup script solved the problem. Now I have music in great quality via DAC connected to USB. Cool!

Now I need to do something with the fan settings, because it is a bit too loud for music in the default settings. Maybe it can be set to automatic mode with a slightly higher threshold temperature, but with less frequent switching on.

Hi _brym, I don’t know this player. For me, it’s important that it can be used with a DAC via USB. Now everything works for me with VLC (see my answer to numbqq). Nevertheless, out of curiosity, I will perhaps try the mpv in the future.

1 Like